Bug 914321 - perl-TryCatch: FTBFS in rawhide
perl-TryCatch: FTBFS in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-TryCatch (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Šabata
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F19FTBFS
  Show dependency treegraph
 
Reported: 2013-02-22 05:01 EST by Dennis Gilmore
Modified: 2013-02-22 11:00 EST (History)
4 users (show)

See Also:
Fixed In Version: perl-TryCatch-1.003000-7.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-22 11:00:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dennis Gilmore 2013-02-22 05:01:53 EST
Your package perl-TryCatch failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=4974712

Build logs:
root.log: http://kojipkgs.fedoraproject.org/work/tasks/4712/4974712/root.log
build.log: http://kojipkgs.fedoraproject.org/work/tasks/4712/4974712/build.log
state.log: http://kojipkgs.fedoraproject.org/work/tasks/4712/4974712/state.log
NOTE: build logs are cleaned up after 1 week

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
Comment 1 Petr Šabata 2013-02-22 11:00:44 EST
Fixed and built in Rawhide.
There were two problems with this package:

1. Incomplete build-time dependency list (added missing deps)
2. A failing test caused by current B::Hooks::EndOfScope (patched, rt#81978)

Note You need to log in before you can comment on or make changes to this bug.