Bug 91454 - kdeinit dies, generating core
kdeinit dies, generating core
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kdelibs (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-22 15:27 EDT by Chris Ricker
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-03 07:23:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2003-05-22 15:27:01 EDT
This is on an up2date'd RHL 9 box, with kdelibs-3.1-11

While I'm in KDE, kdeinit is dying (which apparently takes down the file manager
-- all my icons disappear from the desktop), generating a core dump

Nothing specific seems to trigger this, at least as far as I've determined.

Are there debuginfo RPMs for kdelibs I can download, so I can supply a backtrace
from these core dumps?
Comment 1 Ngo Than 2003-05-23 11:19:09 EDT
there is no debuginfo RPMs for kdelibs for downloading. You have to rebuild
kdelibs yourself to have debuginfo rpm.

Did you restart your machine after upgraded into RHL 9.

It's strange! 
Comment 2 Chris Ricker 2003-05-23 11:21:27 EDT
This was a clean install, not an upgrade

I'll try building the debuginfo myself, but that takes forever ;-)
Comment 3 Chris Ricker 2003-05-23 13:13:00 EDT
I built the kdelibs debuginfo package and installed it. Here's the backtrace:

Reading symbols from /usr/lib/dcopserver.so...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/dcopserver.so
#0  0x4ddddd3c in QApplication::exit(int) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
(gdb) bt
#0  0x4ddddd3c in QApplication::exit(int) ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#1  0x4dddd0d0 in QApplication::quit() ()
   from /usr/lib/qt-3.1/lib/libqt-mt.so.3
#2  0x4000cf1a in DCOPServer::processMessage(_IceConn*, int, unsigned long, int)
() from /usr/lib/dcopserver.so
#3  <signal handler called>
#4  0x4d3f5c50 in _dl_fini () from /lib/ld-linux.so.2
#5  0x4d42ad40 in exit () from /lib/tls/libc.so.6
#6  0x0804ca89 in strcpy ()
#7  0x0804e7ac in strcpy ()
#8  0x4d4166a4 in __libc_start_main () from /lib/tls/libc.so.6
Comment 4 Ngo Than 2003-05-26 16:27:54 EDT
Hmm, perhaps is something broken in your kde config files.

Could you please try to add a new user first and start kde with a new user.
Is the problem still there with new user ?
Comment 5 Chris Ricker 2003-05-29 10:52:32 EDT
This is with a new user

The only perhaps unusual thing is that the user's home directory (and therefore
configs, etc.) are mounted over NFS
Comment 6 Ngo Than 2003-06-03 07:23:03 EDT
Hmm, i still cannot reproduce this bug, even with a new user, which is mounted
over NFS.

sorry, works for me. any more specific way to reproduce this ? reopen then.

Note You need to log in before you can comment on or make changes to this bug.