This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 914568 - wcd: FTBFS in rawhide
wcd: FTBFS in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: wcd (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Erwin Waterlander
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F19FTBFS
  Show dependency treegraph
 
Reported: 2013-02-22 05:32 EST by Dennis Gilmore
Modified: 2013-02-25 06:34 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-25 06:34:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dennis Gilmore 2013-02-22 05:32:02 EST
Your package wcd failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=4983116

Build logs:
root.log: http://kojipkgs.fedoraproject.org/work/tasks/3116/4983116/root.log
build.log: http://kojipkgs.fedoraproject.org/work/tasks/3116/4983116/build.log
state.log: http://kojipkgs.fedoraproject.org/work/tasks/3116/4983116/state.log
NOTE: build logs are cleaned up after 1 week

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
Comment 1 Tim Waugh 2013-02-22 06:30:46 EST
Correct build log is:
http://kojipkgs.fedoraproject.org//work/tasks/8981/5028981/build.log
Comment 2 Erwin Waterlander 2013-02-22 07:08:30 EST
Hi,

The build fails because commands 'podchecker' and 'pod2text' are not found. These commands are part of the perl package.

The RPM file specifies a build requirement on perl.

Could it be that the perl installation was incomplete?

regards,

Erwin
Comment 3 Tim Waugh 2013-02-22 07:14:01 EST
It looks like the perl packaging has changed in Fedora devel.  I think this change might be needed for that branch:

-BuildRequires: perl
+BuildRequires: perl-Pod-Checker

This change works for me when testing with 'fedpkg mockbuild' in the devel branch.
Comment 4 Erwin Waterlander 2013-02-22 09:14:00 EST
OK, thanks. I will try it. You must have seen this too with dos2unix, because dos2unix also uses pod2text.

regards,

Erwin
Comment 5 Tim Waugh 2013-02-22 09:47:01 EST
Thanks, good catch.  There hasn't been a bug filed about that yet (perhaps the rebuild tests haven't got that far) but it also has the same issue.  I'll fix that now.
Comment 6 Erwin Waterlander 2013-02-22 11:29:22 EST
Hi,

I made this change to the spec file:

-BuildRequires: perl
+BuildRequires: perl-Pod-Checker

I pushed it to the server and did a successful Koji build.
wcd-5.2.3-3.fc19

But only a mass rebuild can really prove the problem is solved, isn't it? I assume that the Koji server already had all the required packages installed before.

regards,

Erwin
Comment 7 Tim Waugh 2013-02-22 12:47:54 EST
Each build happens in its own chroot environment, and packages are installed in that environment to satisfy BuildRequires.  It's the same with 'fedpkg mockbuild', except that it happens on the local machine.
Comment 8 Erwin Waterlander 2013-02-22 13:46:40 EST
Hi,

OK. I didn't know that. Then it means it is really fixed.
Thanks.

Erwin
Comment 9 Erwin Waterlander 2013-02-22 17:44:04 EST
Do I have to close this bug now?
Comment 10 Tim Waugh 2013-02-25 05:58:55 EST
Yes.  As this is just rawhide (Fedora devel), there is no need to push an update: having built the new package, it is automatically in Fedora devel.

You can just set the status to CLOSED with resolution RAWHIDE.  Thanks.
Comment 11 Erwin Waterlander 2013-02-25 06:34:20 EST
Thanks. Done.

Note You need to log in before you can comment on or make changes to this bug.