Bug 91460 - NPE when trying to publish a template
Summary: NPE when trying to publish a template
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise CMS
Classification: Retired
Component: other   
(Show other bugs)
Version: nightly
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: ccm-bugs-list
QA Contact: Jon Orris
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 88926
TreeView+ depends on / blocked
 
Reported: 2003-05-22 20:08 UTC by Richard Li
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-03 19:45:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Richard Li 2003-05-22 20:08:26 UTC
Go to a content type.
Create a new template.
Publish the template.

Get:

2003-05-22 16:07:51,423 [xport] ERROR publishToFile.QueueManager - Task
republish on item 14025(parent 14033) failed:  itemId=14025 task=republish on
item 14025(parent 14033) destination=null failCount=10 error=null
java.lang.NullPointerException
	at com.arsdigita.cms.publishToFile.Utilities.getUniqueAssetPath(Utilities.java:496)
	at com.arsdigita.cms.publishToFile.PublishToFile.publish(PublishToFile.java:210)
	at com.arsdigita.cms.publishToFile.PublishToFile.republish(PublishToFile.java:232)
	at com.arsdigita.cms.publishToFile.PublishToFile.doTask(PublishToFile.java:151)
	at
com.arsdigita.cms.publishToFile.QueueManager.processQueueBlock(QueueManager.java:429)
	at
com.arsdigita.cms.publishToFile.QueueManager.processQueueItems(QueueManager.java:358)
	at com.arsdigita.cms.publishToFile.QueueManager.run(QueueManager.java:315)
	at java.lang.Thread.run(Thread.java:512)

Comment 1 Richard Li 2003-06-03 19:45:33 UTC
I can't reproduce this any more.


Note You need to log in before you can comment on or make changes to this bug.