Bug 91462 - xchat 1.8.x in GinGin64 has corrupted pixmaps on AMD64
Summary: xchat 1.8.x in GinGin64 has corrupted pixmaps on AMD64
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: xchat   
(Show other bugs)
Version: 1.0
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Reed
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-22 20:18 UTC by Mike A. Harris
Modified: 2007-03-27 04:04 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-21 17:59:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike A. Harris 2003-05-22 20:18:35 UTC
Running xchat on a stock GinGin64 install on AMD Hammer, results in corrupted
pixmaps everywhere.  I presume this is a 64bit cleanliness issue either in
xchat itself, or in GTK+ on 64bit platforms.  Perhaps even just an x86_64
issue with GTK+.

Owen pointed out a similar bug on GNOME.org which might be related, however
the screenshots from there are not similar in nature to the xchat one it seems.

xchat 1.8.x in GinGin64 is a GTK 1.x application.

I'm going to try running xchat on other 64bit architectures sometime and see
if all 64bit archs are foobed.  Then I'll debug xchat and try to narrow it down
to xchat or GTK being at fault.

Comment 1 Mike A. Harris 2003-05-22 20:36:51 UTC
Here is the similar GNOME bug report for reference:

http://bugzilla.gnome.org/show_bug.cgi?id=105859

Comment 2 Warren Togami 2003-05-27 02:00:13 UTC
Ray, do you see this problem with xchat on your alpha?


Comment 3 Warren Togami 2003-05-27 02:01:22 UTC
(Note, test a rebuild of xchat-1.x from RH9 on alpha.  Rawhide currently has
xchat-2.0.2.)


Comment 4 Ray Strode 2003-05-27 03:18:36 UTC
Note i'm not running Red Hat on my alpha anymore.  I downloaded the rpms
extracted them, patched them and compiled everything with the same flags as the
rpm though, and i'm not able to reproduce (I know...hardly conclusive). It seems
to work fine for me when i compile gdk-pixbuf support into xchat and also when i
don't.  Nevertheless, I have a feeling it is a problem with gdk-pixbuf's pixops.
I remember getting pixel corruption a while ago, for some scaling modes in
gdk-pixbuf back when it first got merged with gtk+, so it's conceivable to me
that a similar problem could popup in the standalone version of gdk-pixbuf.

Mike, does the problem still happen if you compile xchat w/o gdk-pixbuf support?

Comment 5 Daniel Reed 2004-05-21 17:59:35 UTC
Please reopen if this is still relevant.


Note You need to log in before you can comment on or make changes to this bug.