Bug 914623 - cpupower set -m doesn't work
Summary: cpupower set -m doesn't work
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cpupowerutils
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Neil Horman
QA Contact: Jeff Bastian
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-02-22 10:38 UTC by Jaroslav Škarvada
Modified: 2013-11-21 04:39 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2013-11-21 04:39:48 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1533 normal SHIPPED_LIVE cpupowerutils bug fix and enhancement update 2013-11-20 21:40:59 UTC

Description Jaroslav Škarvada 2013-02-22 10:38:02 UTC
Description of problem:
cpupower set -m doesn't work. From the source code it seems this feature is not implemented, but the error message is misleading and can be wrongly interpreted as the feature is not supported by your platform.

Version-Release number of selected component (if applicable):
cpupowerutils-1.1-1.el6

How reproducible:
Always

Steps to Reproduce:
1. echo 0 > /sys/devices/system/cpu/sched_mc_power_savings; cat /sys/devices/system/cpu/sched_mc_power_savings
2. cpupower set -m 0
  
Actual results:
0
Error setting sched-mc not supported

Expected results:
0
sched-mc set

Additional info:
I think it would be enough to change the message to something like:
Error setting sched-mc not implemented

or remove the feature entirely (upstream kernel drops the sched_mc_power_savings).

Comment 12 errata-xmlrpc 2013-11-21 04:39:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1533.html


Note You need to log in before you can comment on or make changes to this bug.