Bug 91470 - /usr/include/freetype doesn't exist
Summary: /usr/include/freetype doesn't exist
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: freetype   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-22 21:37 UTC by acount closed by user
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-22 21:45:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description acount closed by user 2003-05-22 21:37:04 UTC
Description of problem:

the header file /usr/X11R6/include/X11/Xft/Xft.h has  #include
<freetype/freetype.h>, but /usr/include/freetype doesn't exist.
Only /usr/include/freetype2/ and /usr/include/freetype1 are real
directories.

-thanks-

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:

Comment 1 Owen Taylor 2003-05-22 21:45:23 UTC
You need to get the compilation flags for Xft using:

 pkg-config --cflags xft

Which gives, as it turns out:

 -I/usr/X11R6/include -I/usr/include/freetype2

(If you are just using freetype and not Xft, you can use the
freetype-config script for the same purpose.)




Note You need to log in before you can comment on or make changes to this bug.