Bug 914787 - cpupower -v reports version ".."
Summary: cpupower -v reports version ".."
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cpupowerutils
Version: 6.5
Hardware: x86_64
OS: Unspecified
unspecified
low
Target Milestone: rc
: ---
Assignee: Neil Horman
QA Contact: Jeff Bastian
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-02-22 18:55 UTC by Petr Beňas
Modified: 2015-01-04 23:04 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-11-21 04:39:54 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1533 normal SHIPPED_LIVE cpupowerutils bug fix and enhancement update 2013-11-20 21:40:59 UTC

Description Petr Beňas 2013-02-22 18:55:23 UTC
Description of problem:
Version information is incorrect for cpupower binary.

Version-Release number of selected component (if applicable):
cpupowerutils-1.1-2.el6.x86_64

Steps to Reproduce:
cpupower -v / cpupower --version
  
Actual results:
[root@sgi-xe250-02 ~]# cpupower --version
cpupower ..
Report errors and bugs to cpufreq@vger.kernel.org, please.
[root@sgi-xe250-02 ~]# cpupower -v
cpupower ..


Additional info:
utils/version-gen.sh cannot find Makefile
[root@sgi-xe250-02 cpupower]# grep -rn 'VERSION' .
./Makefile:60:VERSION=                  $(shell ./utils/version-gen.sh)
./Makefile:124:CFLAGS += -DVERSION=\"$(VERSION)\" -DPACKAGE=\"$(PACKAGE)\" \
grep: ./libcpupower.so: No such file or directory
./utils/version-gen.sh:6:# Heavily based on tools/perf/util/PERF-VERSION-GEN .
./utils/version-gen.sh:25:      eval $(grep '^VERSION[[:space:]]*=' ../../../Makefile|tr -d ' ')
./utils/version-gen.sh:28:      eval $(grep '^EXTRAVERSION[[:space:]]*=' ../../../Makefile|tr -d ' ')
./utils/version-gen.sh:30:      VN="${VERSION}.${PATCHLEVEL}.${SUBLEVEL}${EXTRAVERSION}"
./utils/cpupower.c:111: printf(PACKAGE " " VERSION "\n");
[root@sgi-xe250-02 cpupower]# sh ./utils/version-gen.sh
grep: ../../../Makefile: No such file or directory
grep: ../../../Makefile: No such file or directory
grep: ../../../Makefile: No such file or directory
grep: ../../../Makefile: No such file or directory
..

Comment 12 errata-xmlrpc 2013-11-21 04:39:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1533.html


Note You need to log in before you can comment on or make changes to this bug.