Bug 914908 - elfutils-0.155-4.fc19 tests fail on ARM
elfutils-0.155-4.fc19 tests fail on ARM
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: elfutils (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Roland McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2013-02-23 06:07 EST by Peter Robinson
Modified: 2013-08-14 22:37 EDT (History)
6 users (show)

See Also:
Fixed In Version: elfutils-0.156-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-25 03:07:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2013-02-23 06:07:13 EST
http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=1466963

section [ 5] '.dynsym': symbol 18: st_value out of bounds
section [38] '.symtab': symbol 318: st_value out of bounds
*** failure in ../src/elflint --quiet --gnu-ld ../src/nm
section [38] '.symtab': symbol 255: st_value out of bounds
*** failure in ../src/elflint --quiet --gnu-ld ../src/objdump
section [ 5] '.dynsym': symbol 91: st_value out of bounds
section [38] '.symtab': symbol 529: st_value out of bounds
*** failure in ../src/elflint --quiet --gnu-ld ../src/readelf
section [36] '.symtab': symbol 122: st_value out of bounds
*** failure in ../src/elflint --quiet --gnu-ld ../src/size
section [38] '.symtab': symbol 292: st_value out of bounds
*** failure in ../src/elflint --quiet --gnu-ld ../src/strip
FAIL: run-elflint-self.sh
Comment 1 Mark Wielaard 2013-02-23 08:03:56 EST
That is caused by:

    0.155-4 Replace elfutils-0.155-binutils-pr-ld-13621.patch with upstream fix.

In the worst case we can go back to the previous hack. But that hides other problems.

Could someone upload the problematic binaries (src/size is probably the smallest) from a native arm build? So we can inspect which symbol it really is that causes trouble?
Comment 2 Mark Wielaard 2013-02-24 17:03:14 EST
Got access to an arm system (f18, armv7hl.tegra, gcc 4.7.2-8, binutils-2.23.51.0.1-3.fc18.armv7hl).

Looks like the issue is that arm is using the symbol name "__bss_start__" instead of "__bss_start" Only "__bss_start" is handled specially by eu-elflint --gnu.

https://lists.fedorahosted.org/pipermail/elfutils-devel/2013-February/002967.html
Comment 3 Mark Wielaard 2013-02-25 03:07:43 EST
Fixed in elfutils-0.155-5.fc19:

- Add ARM variant to elfutils-0.155-binutils-pr-ld-13621.patch rhbz#914908.
Comment 4 Fedora Update System 2013-08-08 07:16:55 EDT
elfutils-0.156-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/elfutils-0.156-3.fc19
Comment 5 Fedora Update System 2013-08-14 22:37:57 EDT
elfutils-0.156-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.