Bug 91499 - Apache Conf File Missing MultiViews Config Parm
Apache Conf File Missing MultiViews Config Parm
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-httpd (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-23 09:04 EDT by Greg Bunker
Modified: 2015-03-04 20:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-01 09:29:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Bunker 2003-05-23 09:04:34 EDT
Description of problem:
This is an out of the box install of redhat 9.0, custom, with the webserver 
and dev tools selected.  Upon configuration of the apache webserver and 
bringing up the ErrorIndex default page as configured, the documentation is 
not accessible from the default page.  I have found this to be because 
the /manual directory is setup for language extension negotiation but without 
the MultiViews option for the /manuals directory, the index page (and 
subsequent pages) are not retreivable.  I corrected this by including the 
<Directory "/var/www/manual"> information from the base .conf file as 
distributed by apache.org.  Shouldn't this option be available for the redhat 
distribution of the apache server?  If so, the basic conf file used by the 
configuration tool should be modified to generate the correct options so that 
language negotiation with the browser is available.


Version-Release number of selected component (if applicable):
redhat v9.0, apache distribution is 2.040 (I believe).


How reproducible:
All the time unless MultiViews option included in the .conf file for 
the /manuals directory.


Steps to Reproduce:
1. Install linux and apache out of the box.
2. Minimal configuration requirements (install script) after the install.
3. Point browser to server, get the basic ErrorIndex.html screen saying 
that "If you can read this your install was good".
4. Attempt to follow the documentation link and it will fail with page not 
found because language selection is not enabled.
    
Actual results:


Expected results:


Additional info: This was initially reported to installation support as 
service request #237041.  They referred me to this site since it probably is a 
distribution configuration bug.
Comment 1 Phil Knirsch 2003-11-27 06:26:35 EST
Reassinging to r-c-h and myself.

Read ya, Phil
Comment 2 Phil Knirsch 2004-09-01 09:29:31 EDT
In the lastest Fedora Core versions the original httpd.conf we ship
doesn't reference to the manual anymore, so i'm closing this as not a
bug as the need for a reference to the manual has gone.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.