Bug 91500 - Redhat 7.3: Latest Kernel Update Breaks iptables "--match owner"
Redhat 7.3: Latest Kernel Update Breaks iptables "--match owner"
Status: CLOSED DUPLICATE of bug 91374
Product: Red Hat Linux
Classification: Retired
Component: iptables (Show other bugs)
7.3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-23 09:16 EDT by Jason Burgess
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:53:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Burgess 2003-05-23 09:16:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.2)
Gecko/20030208 Netscape/7.02

Description of problem:
Just did an 'up2date' for my Linux Redhat 7.3 machine which installed,
amoung other things, kernel v2.4.20-13.7. Previously I was working
with v2.4.18-27.7.x where the command:

'iptables -t mangle -A OUTPUT -j MARK --set-mark 1 -m owner --uid 501'

used to work without issue.

Now, when giving the same command under the new kernel (with a verbose
option this time) gives:

'iptables -v -t mangle -A OUTPUT -j MARK --set-mark 1 -m owner --uid
501

MARK  all opt -- in * out *  0.0.0.0/0  -> 0.0.0.0/0  OWNER UID match
501 MARK set 0x1
iptables: Invalid argument
'

lsmod shows the ipt_owner module loaded, amoung others, so I know the
module is working. I checked the source for the module but could not
for the life of me determine what the problem is here.

Rebooting to the old kernel seems to allow this command to work again.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot into newest kernel for RH 7.3 Athlon
2. type iptables -t mangle -A OUTPUT -j MARK --set-mark 1 -m owner --uid
501
3. Should return "iptables: Invalid argument"
    

Additional info:
Comment 1 Michael Schwendt 2003-05-27 11:32:42 EDT
See bug #91374.
Comment 2 Jason Burgess 2003-05-27 12:17:19 EDT

*** This bug has been marked as a duplicate of 91374 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:53:13 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.