Bug 91502 - 'Probe for mouse' option corrupts the ks.cfg
'Probe for mouse' option corrupts the ks.cfg
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-kickstart (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-23 09:44 EDT by Brian Baggett
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-23 12:20:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Baggett 2003-05-23 09:44:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

Description of problem:
While using this program, if one leaves the mouse setting set to "Probe for
mouse", a comment gets written in the resulting ks.cfg that looks like this:

#System mouse
mouse #Probe for mouse

This causes the kickstart to fail.  Removing the "#Probe for mouse" part fixes this.


Version-Release number of selected component (if applicable):
2.3.6-4

How reproducible:
Always

Steps to Reproduce:
1. run redhat-config-kickstart
2. Choose "Probe for mouse"
3. Try to kickstart using the ks.cfg you created.  Anaconda will error out with
a python error indicating that the "#Probe for mouse" directive is not understood.
    

Actual Results:  The kickstart errors out.

Expected Results:  The kickstart works if the line is removed.

Additional info:
Comment 1 Brent Fox 2003-05-23 12:20:54 EDT
Ah.  I thought that anaconda's kickstart parser would ignore midline comments,
but apparently not.  I've removed the comment so that the line just says 'mouse'
now.  This should cause anaconda to probe for the mouse.

Should be fixed in redhat-config-kickstart-2.3.8-1 and should appear in Rawhide
soon.  Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.