This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 91503 - Runtime Error forces me to Kill app
Runtime Error forces me to Kill app
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: libuser (Show other bugs)
9
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-23 10:03 EDT by Justin Churchey
Modified: 2007-04-18 12:53 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.2.4-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-15 19:43:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Simple python program to demonstrate libuser bug (308 bytes, application/octet-stream)
2003-07-11 17:08 EDT, Brent Fox
no flags Details

  None (edit)
Description Justin Churchey 2003-05-23 10:03:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030410

Description of problem:
When adding user to groups (apache and mysql), dialog goes grey as if
processing, but terminal returns the following message:

Traceback (most recent call last):
  File "/usr/share/redhat-config-users/userProperties.py", line 502, in
on_ok_button_clicked
    self.parent.ADMIN.modifyUser(self.userEnt)
RuntimeError: unknown error                                     

I also had to change the username b/c the program did not support underscores in
the username, which has been there since I installed HR initially as 7.3.


Version-Release number of selected component (if applicable):
1.1.5-7

How reproducible:
Always

Steps to Reproduce:
1.I choose my user and click properties
2.Go to the groups tab and add the user to the two groups mentioned
3.Change the username
4.Click the Apply button
    

Actual Results:  Program freezes, terminal outputs the Runtime Error, and I am
forced to kill the program.

Expected Results:  Program adds users to the appropriate groups.

Additional info:

Using WindowMaker that came installed w/ RH 9.0, if that is of any importance. 
I had a similar problem that caused for the deletion of the user and the loss of
their preferrences. Had to recreate the user and attempt to restore link between
user and the preferrences using

chown -R
Comment 1 Brent Fox 2003-07-11 17:07:22 EDT
Actually, this looks like a bug in libuser.

Nalin, can you take a look at this?  I'm attaching a simple python progam that
demonstrates the problem on my test machine.  BTW, this problem still exists in
our most recent development tree.
Comment 2 Brent Fox 2003-07-11 17:08:49 EDT
Created attachment 92890 [details]
Simple python program to demonstrate libuser bug
Comment 3 Brent Fox 2003-07-11 17:11:03 EDT
When running that program on my machines, I get the following traceback:

Traceback (most recent call last):
  File "/tmp/change_username.py", line 15, in ?
    a.modifyUser(userEnt)
RuntimeError: unknown error
Comment 4 Justin Churchey 2003-07-11 21:35:43 EDT
What kind of problems can be wrong w/ the libuser library?  What exactly is this
bug doing?

Note You need to log in before you can comment on or make changes to this bug.