This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 915051 - RFE: journalctl -t as a synonym for --since=today
RFE: journalctl -t as a synonym for --since=today
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
Unspecified Unspecified
low Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks: systemd-RFE
  Show dependency treegraph
 
Reported: 2013-02-24 08:49 EST by Matthew Miller
Modified: 2013-04-09 07:17 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-09 07:17:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthew Miller 2013-02-24 08:49:14 EST
This is a low-priority RFE. My servers tend to have long uptimes, and when they reboot, I often want to know what happened just before that. So, I find myself typing

   journalctl --since today

quite often. It would be nice to have a shortcut, and -t isn't used. I know this is a slippery slope, but we already have -b, and this seems likely to be pretty common for more people than me.
Comment 1 Lennart Poettering 2013-03-07 21:48:45 EST
Well, but the next guy then wants -w for --since=-7days, and another one wants -t to be --since=-24h and so on... I am not convinced we should give one of them a shortcut...
Comment 2 Matthew Miller 2013-03-08 09:09:45 EST
I know it's got to end somewhere, but what are shortcuts for? :)

I've already got some aliases, so I don't think there's a real need to push very hard on this one; I just see "-b" being given a lot party because it's so short and handy, and I think often "--since=today" would actually be more helpful but isn't used because of the typing (particularly when recommending it to someone else).
Comment 3 Lennart Poettering 2013-04-09 07:17:18 EDT
OK, I am not convinced we want this. Sorry. Closing.

Note You need to log in before you can comment on or make changes to this bug.