Bug 91553 - Can't compile 2.4.20-13.8 (make modules fails)
Can't compile 2.4.20-13.8 (make modules fails)
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-23 19:05 EDT by Joseph Shraibman
Modified: 2007-04-18 12:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-12 17:50:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joseph Shraibman 2003-05-23 19:05:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
I configured my kernel, then did a make dep, make, then make modules, which
failed with:

/usr/src/linux-2.4.20-13.8/include/linux/module.h:187: parse error before numeri
c constant
/usr/src/linux-2.4.20-13.8/include/linux/module.h:187: `inter_module_put_R_ver_s
tr' declared as function returning a function
/usr/src/linux-2.4.20-13.8/include/linux/module.h:187: warning: function declara
tion isn't a prototype
/usr/src/linux-2.4.20-13.8/include/linux/module.h:196: `try_inc_mod_count_R_ver_
str' declared as function returning a function
/usr/src/linux-2.4.20-13.8/include/linux/module.h:196: warning: parameter names
(without types) in function declaration
loop.c: In function `loop_change_fd':
loop.c:761: warning: label `out_put_all' defined but not used
make[2]: *** [loop.o] Error 1
make[2]: Leaving directory `/usr/src/linux-2.4.20-13.8/drivers/block'
make[1]: *** [_modsubdir_block] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.20-13.8/drivers'
make: *** [_mod_drivers] Error 2


Version-Release number of selected component (if applicable):


How reproducible:
Always


Additional info:

I need to compile the kernel because 
a) apm isn't working on my laptop, and I want to try to compile it in if it
isn't in the default kernel
b) I need to support my FTDI usb serial port 

Does anyone know if I can do these things without a recompile?
Comment 1 Alan Cox 2003-06-08 08:59:12 EDT
APM is included by default in the Red Hat kernels.

When rebuilding from the Red Hat source tree make sure you do a make mrproper 
(copy your .config somewhere first then copy it back and make oldconfig)
Comment 2 Henrik Nordstrom 2003-06-12 15:55:22 EDT
Same problem with RH9 kernel-2.4.20-18.9 
Comment 3 Henrik Nordstrom 2003-06-12 17:13:19 EDT
"make mrproper" indeed seems to fix the build problem. 

Note You need to log in before you can comment on or make changes to this bug.