Bug 91554 - Anaconda fails to update existing 9.0 installation to 9.0
Anaconda fails to update existing 9.0 installation to 9.0
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-23 19:07 EDT by Bert Sweetman
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-24 19:31:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log file produced by anaconda (48.10 KB, text/plain)
2003-05-23 19:09 EDT, Bert Sweetman
no flags Details

  None (edit)
Description Bert Sweetman 2003-05-23 19:07:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130

Description of problem:
I had attempted to make an exact copy of an exiting linux installation by
identically formatting (partition using fdisk, ext3 using mke2fs and confirming
via fsck) an identical hard drive  then mirroring the existing linux
installation onto the new drive via dump.  Finally, I made the partition
bootable (again with fdisk).  I had successfully used this method in the past.  

Unfortunately, the new copy would not boot.  Suspecting a hardware problem, I
ran the mke2fs -cc option on every partion and found no problems.

I repeated the mirroring via dump, and again could not boot.  At this point I
gave up the idea of copying the existing linux and ran the redhat 9.0 installion
CD to build a new linux from the start.

The new linux failed, teh log file of which is attached.

After this failure, I moved the hard drive to a windows machine to reformat to
NTFS, then again ran anaconda to reformat to the original configuration and
finally succcessfully installed redhat 9.0 on the new drive. 


Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:
Comment 1 Bert Sweetman 2003-05-23 19:09:10 EDT
Created attachment 91937 [details]
log file produced by anaconda
Comment 2 Michael Fulbright 2003-05-27 12:49:47 EDT
It would help diagnose the issue to have the /etc/fstab file from the system you
were upgrading. The failure occurred trying to mount the '/' filesystem.
Comment 3 Bert Sweetman 2003-05-28 16:18:29 EDT
Sadly, the fstab is no more.  Sorry I no longer have it, but I will try to
describe its contents as I remember them:

The first section was exactly as created by the anaconda installer.  This all
referred to hda (since only hda was present when that was first run).  I copied
the hard drive part of that first section and changed all the device names to
explicit /dev/hdb's, and then made each of the hdb's non auto mounting.

After I first ran into trouble, I suspected it might be due to some confusion
between the hda's and hdb's.  I next tried making all the device names
explicitly either hda's or hdb's.  Still suspecting confusion between the hda's
and hdb's, I next tried switching all the a's and b's (i.e. switching which
drives are not supposed to automount).  None of these was successful, and I am
afraid I am no longer really certain whether the file I sent was from the last
or second-to-last try (which switch of hda's and hdb's).  Sorry. 

Comment 4 Michael Fulbright 2003-06-19 14:59:03 EDT
So to make sure I understand - you are now trying to do a fresh install of RHL 9
and got the error message above?
Comment 5 Bert Sweetman 2003-06-19 15:28:23 EDT
Correct.  I was attempting a fresh install of RH9 onto a hard drive which had
previously been formatted (ext3) by RH9.  The problem was solved by reformatting
the drive to ntfs, then letting anaconda again reformat to ext3.
Comment 6 Jeremy Katz 2003-07-24 19:31:23 EDT
This would have led to having duplicate labels on your filesystems.  I've added
a check to CVS that will prevent this from being a problem in the future.

Note You need to log in before you can comment on or make changes to this bug.