Bug 915674 - Output of <computeroutput> tag not formatted correctly in generated HTML
Output of <computeroutput> tag not formatted correctly in generated HTML
Status: CLOSED DUPLICATE of bug 752851
Product: Publican
Classification: Community
Component: publican (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Fearn
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-26 05:09 EST by Fintan Bolton
Modified: 2013-02-26 17:46 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-26 05:28:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Fintan Bolton 2013-02-26 05:09:56 EST
Description of problem:

When the output is generated for a <computeroutput> tag, the text content runs all on a single line (i.e. there are no newlines in the output).


Version-Release number of selected component (if applicable): Tested in publican 3.0


How reproducible:

Sample XML source
-----snip-----
      <screen><prompt>FuseMQ:karaf@root></prompt> <userinput>help</userinput>
<computeroutput>COMMANDS
        activemq:browse
        activemq:bstat
        activemq:list
        activemq:purge
        activemq:query
        admin:change-opts
                Changes the Java options of an existing container instance.
        admin:change-rmi-registry-port
                Changes the RMI registry port (used by management layer) of an 
                existing container instance.</computeroutput>
    ...
<prompt>FuseMQ:karaf@root></prompt></screen>
-----snip-----

Here is roughly what the generated HTML looks like

-----snip-----
FuseMQ:karaf@root> help
COMMANDS activemq:browse activemq:bstat activemq:list activemq:purge activemq:query admin:change-opts Changes the Java options of an existing container instance. admin:change-rmi-registry-port Changes the RMI registry port (used by management layer) of an existing container instance.
    ...
FuseMQ:karaf@root>
-----snip-----

And here is what it *ought* to look like

-----snip-----
FuseMQ:karaf@root> help
COMMANDS
        activemq:browse
        activemq:bstat
        activemq:list
        activemq:purge
        activemq:query
        admin:change-opts
                Changes the Java options of an existing container instance.
        admin:change-rmi-registry-port
                Changes the RMI registry port (used by management layer) of an 
                existing container instance.
    ...
FuseMQ:karaf@root>
-----snip-----


Additional info:
Comment 1 Fintan Bolton 2013-02-26 05:28:01 EST
Didn't immediately spot that this issue is a duplicate of 751851. Having looked up this tag in 'DocBook5: The Definitive Guide', I am inclined to agree with Jeff's analysis. Norman Walsh states quite plainly that it's an inline element, not a verbatim.

*** This bug has been marked as a duplicate of bug 752851 ***
Comment 2 Jeff Fearn 2013-02-26 17:46:06 EST
Just a note that for people who disagree with my interpretation, and this is the Internet, you can easily change this behavior in a brand by adding something like the following in your brand's overrides.css & menu.css files.

.screen .computeroutput {
    white-space: pre-wrap;
}

Note You need to log in before you can comment on or make changes to this bug.