Bug 915769 - coroparse: Read unitialized memory if config file contains service without name
coroparse: Read unitialized memory if config file contains service without name
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: corosync (Show other bugs)
6.4
All All
low Severity low
: rc
: ---
Assigned To: Jan Friesse
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-26 08:30 EST by Jan Friesse
Modified: 2013-11-20 23:32 EST (History)
4 users (show)

See Also:
Fixed In Version: corosync-1.4.1-16.el6
Doc Type: Bug Fix
Doc Text:
Cause: Start corosync with config file where service subsection doesn't contain name key. Consequence: Segfault or refuse to load service with "random garbage" name (access to unitialized memory) Fix: Properly check if name key exists. Result: Corosync will display error and exits properly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-20 23:32:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (3.46 KB, patch)
2013-02-26 08:30 EST, Jan Friesse
no flags Details | Diff

  None (edit)
Description Jan Friesse 2013-02-26 08:30:44 EST
Created attachment 702869 [details]
Proposed patch

Description of problem:
SSIA

Version-Release number of selected component (if applicable):
Flatiron

How reproducible:
100%

Steps to Reproduce:
1. Add following to config file:

service {
    ver: 1
}

2. Start corosync
  
Actual results:
Corosync will ether receive segfault or displays something like "Loading service GARBAGE" where GARBAGE is result of unitialized memory (so random value)

Expected results:
Corosync will properly check given condition and displays error.

Additional info:

"Unit" test:

https://github.com/jfriesse/csts/commit/47e51465ece64dd49d2d2648e7bc3cffc14889c8

Before patch result:
$? != 0

After patch result:
$? == 0
Comment 8 Jaroslav Kortus 2013-09-11 12:06:47 EDT
Verified with config-service-without-name.sh:

FAIL on corosync-1.4.1-15.el6.x86_64 (RHEL6.4) (coredump)
PASS on corosync-1.4.1-17.el6.x86_64 (RHEL6.5)
Sep 11 18:05:22 virt-014 corosync[4070]:   [SERV  ] Service section defined in config file without name key
Sep 11 18:05:22 virt-014 corosync[4070]:   [MAIN  ] Corosync Cluster Engine exiting with status 13 at main.c:1501.
Comment 10 errata-xmlrpc 2013-11-20 23:32:55 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1531.html

Note You need to log in before you can comment on or make changes to this bug.