Bug 915988 - /usr/lib/firewalld/zones/drop.xml is not readable by everyone
Summary: /usr/lib/firewalld/zones/drop.xml is not readable by everyone
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: firewalld
Version: rawhide
Hardware: noarch
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-02-26 22:53 UTC by Cristian Ciupitu
Modified: 2015-01-06 06:15 UTC (History)
2 users (show)

Fixed In Version: firewalld-0.3.13-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-06 06:12:58 UTC
Type: Bug


Attachments (Terms of Use)

Description Cristian Ciupitu 2013-02-26 22:53:03 UTC
Description of problem:
The file /usr/lib/firewalld/zones/drop.xml is not readable by everyone even if it should be. After all, if it's under /usr, it's not a configuration file, so there's no need to make it a secret.

Version-Release number of selected component (if applicable):
firewalld-0.2.12-2.fc18.noarch

How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Thomas Woerner 2013-06-06 11:59:38 UTC
It is the default configuration for the zone drop. All zone files in /usr/lib/firewalld/zones are only readable by user and group root. These files should not be modified. If a zone gets customized or modified, it gets copied over to /etc/firewalld/zones/. This applies also for services and icmptypes.

We thought about moving these files to some directory in /etc.

Comment 2 Thomas Woerner 2013-06-06 12:01:06 UTC
I am closing this as not a bug.

Comment 3 Cristian Ciupitu 2013-06-06 23:51:56 UTC
If the files aren't to be modified and are the same as in the RPM, I don't see the point in making it private for regular users. The user could download and analyze the RPM, but why make things harder than they should be?

Comment 4 Cristian Ciupitu 2013-07-31 06:25:50 UTC
It still happens in Fedora 19, firewalld-0.3.3-2.fc19.noarch.

Comment 5 Jiri Popelka 2014-11-03 11:11:55 UTC
Neither I see any reason why the files under /usr/lib/firewalld/ (unlike /etc/firewalld/) should be readable only by root. It's no secret what's in those files. I'd say it's 'security by obscurity' by I don't see any security here.

Also  https://fedorahosted.org/fpc/ticket/467

Comment 7 Fedora Update System 2014-12-04 18:44:58 UTC
firewalld-0.3.13-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/firewalld-0.3.13-1.fc21

Comment 8 Fedora Update System 2014-12-04 18:45:32 UTC
firewalld-0.3.13-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/firewalld-0.3.13-1.fc20

Comment 9 Fedora Update System 2014-12-05 00:48:05 UTC
Package firewalld-0.3.13-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing firewalld-0.3.13-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-16322/firewalld-0.3.13-1.fc21
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2015-01-06 06:12:58 UTC
firewalld-0.3.13-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2015-01-06 06:15:45 UTC
firewalld-0.3.13-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.