Bug 916 - Mode timings messed up after update to XFree86-3.3.3.1
Mode timings messed up after update to XFree86-3.3.3.1
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
5.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-01-22 01:01 EST by Brian Ryner
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-03-22 16:34:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Ryner 1999-01-22 01:01:45 EST
After updating to XFree86 3.3.3.1 via the RPMs on
updates.redhat.com, my monitor/video card are no longer
getting the correct hsync and vsync.  I have a Diamond Viper
330 card, and a MAG DJ530 monitor, and was attempting to set
up 800x600x32bpp mode.  I've rerun xf86config several times,
and tried commenting out modelines to make sure it selects
the right ones.  All this was working great before the
update.
Comment 1 David Lawrence 1999-01-22 15:46:59 EST
We currently do not have a Diamond Viper 330 video card to replicate
this problem with. We will need to get one into our test lab as soon
as possible. Until then you may want to try our supported mailing
lists at http://archive.redhat.com to see if anyone else has posted a
solution to this issue.
Comment 2 Brian Ryner 1999-01-22 17:06:59 EST
I backdated to the 3.3.2.3 version that comes with the 5.2 dist, and
the problem disappeared.  I am looking for the 3.3.3 update RPM's that
were posted before the 3.3.3.1 release, because that version also
worked fine.
Comment 3 Brian Ryner 1999-02-02 15:34:59 EST
Have not verified yet but I may have found the reason for this.  The
main XFree86-3.3.3.1 package contains /usr/X11R6/lib//X11/XF86Config.
This is a change of location from /etc/X11/XF86Config, and this path
is looked at BEFORE /etc/X11.  Hence, changes to /etc/X11/XF86Config
were not taking effect.
Comment 4 Brian Ryner 1999-02-02 17:17:59 EST
Actually, disregard previous comment as I see it's actually a link to
/etc/X11.  Sorry about that... I saw the path problem on another
system and thought it might apply here.

Note You need to log in before you can comment on or make changes to this bug.