Bug 91607 - Incorrect parameters for AVM PCI (Fritz!PCI v2) in file isdncard
Incorrect parameters for AVM PCI (Fritz!PCI v2) in file isdncard
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks: rcn-isdn
  Show dependency treegraph
 
Reported: 2003-05-25 16:02 EDT by Uwe Beck
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-29 11:59:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Uwe Beck 2003-05-25 16:02:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.08 [en] (X11; I; AIX 4.3)

Description of problem:
The configuration for the AVM PCI (Fritz!PCI v2) is correct in
/etc/sysconfig/isdncard if you create the card over the hardware menu.

/etc/sysconfig/isdncard
NAME="AVM PCI (Fritz!PCI v2)"
MODULE="hisax_fcpcipnp"
VENDOR_ID="1244"
DEVICE_ID="0e00"
RESOURCES="protocol=2"

After configure a provider the parameters in /etc/sysconfig/isdncard are
incorrect.

/etc/sysconfig/isdncard
NAME="AVM PCI (Fritz!PCI v2)"
MODULE="hisax_fcpcipnp"
VENDOR_ID="1244"
DEVICE_ID="0e00"
RESOURCES="NONE"

The RESOURCES="NONE" means, this card is a PCMCIA card -> see
/etc/rc.d/init.d/isdn.

# check PCMCIA
if [ "$RESOURCES" = "NONE" ] ; then
    PCMCIA=yes
fi

That is the reason, that the system can not load the modules for the AVM PCI
(Fritz!PCI v2) at boot time. So if-up can not activate the ippp interface.

You can correct the RESOURCES parameter by hand. If you use the
redhat-config-network program the next time for another task the file isdncard
is write back with RESOURCES="NONE".


Version-Release number of selected component (if applicable):
redhat-config-network-1.2.0-2

How reproducible:
Always

Steps to Reproduce:
1. Configure AVM PCI (Fritz!PCI v2)
2. Configure a provider
3. reboot
or
use redhat-config-network after you have correct the RESOURCE parameter by hand
again.

Additional info:

Same problem with redhat-config-network in Red Hat 8.0.
Comment 1 Harald Hoyer 2003-05-26 07:23:57 EDT
does the version on 
http://people.redhat.com/harald/redhat-config-network
fix your problem?
Comment 2 Uwe Beck 2003-05-26 14:52:03 EDT
I install the new versions with 
rpm -Uhv redhat-config-network-1.2.7-1.noarch.rpm \
redhat-config-network-tui-1.2.7-1.noarch.rpm \
rhpl-0.100.3-1.i386.rpm

The same problem. I remove the ISDN-card and create the card new. The
parameter in /etc/sysconfig/isdncard are correct for the AVM PCI (Fritz!PCI v2)
at this time.
If you edit then the provider, e.g switch a compression parameter off and once
again on, then you must save the change before you can exit the program.
Now you can find RESOURCE="NONE" in the file /etc/sysconfig/isdncard.
Comment 3 Harald Hoyer 2003-06-17 10:07:15 EDT
ok... 1.2.12 on:
http://people.redhat.com/harald/redhat-config-network

you may have to downgrade rhpl
Comment 4 Uwe Beck 2003-06-26 16:08:00 EDT
I tested first the version redhat-config-network-1.2.12-1

The parameter for the isdn AVM PCI (Fritz!PCI v2) now correct in the file
isdncard.

But I see some other problems with the new version.

I create my provider by name "brickxmp".

/etc/sysconfig/network-scripts
ifcfg-eth0
ifcfg-eth1
ifcfg-brickxmp <-- ifcfg-ippp0 before the new program version

After the system was rebooted:

netstat -r
Kernel IP Routentabelle
Ziel            Router          Genmask         Flags   MSS Fenster irtt Iface
172.16.39.0     *               255.255.255.0   U         0 0          0 eth0
172.16.38.0     *               255.255.255.0   U         0 0          0 ippp0
172.16.37.0     *               255.255.255.0   U         0 0          0 eth1
169.254.0.0     *               255.255.0.0     U         0 0          0 eth1
127.0.0.0       *               255.0.0.0       U         0 0          0 lo
default         lex021          0.0.0.0         UG        0 0          0 eth0

The default route is set over eth0, but should be set over ippp0. Before this
version of redhat-config-network the ISDN-interface name was always ippp0.
This mistake comes from the loop in the if-up script and it was a random that
I have this mistake found because my providername is "brickxmp".

I see some effects if the name is ifcfg-brickxmp.

With /etc/sysconfig/network-scripts/ifcfg-brickxmp the kisdndock do not go
in the o.k. status (color gray) on the KDE desktop.

service network stop
Interface eth0 herunterfahren:                             [  OK  ]
Interface eth1 herunterfahren:                             [  OK  ]
Loopback Interface herunterfahren:                         [  OK  ]

The ISDN-interface shutdown is missing.

ifdown ippp0
Verwendung: ifdown <Gerätename>

But:

ifconfig
ippp0     Protokoll:Punkt-zu-Punkt Verbindung
          inet Adresse:192.168.20.11  P-z-P:172.16.38.1  Maske:255.255.255.0
          UP PUNKTZUPUNKT RUNNING NOARP  MTU:1500  Metric:1
          RX packets:9 errors:0 dropped:0 overruns:0 frame:0
          TX packets:11 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:30
          RX bytes:359 (359.0 b)  TX bytes:517 (517.0 b)

netstat -r
Kernel IP Routentabelle
Ziel            Router          Genmask         Flags   MSS Fenster irtt Iface
172.16.38.0     *               255.255.255.0   U         0 0          0 ippp0

ifdown brickxmp
Ziel            Router          Genmask         Flags   MSS Fenster irtt Iface

Now you can see, why the default route is not set over ippp0.

service network start
Netzwerkparameter einstellen:                              [  OK  ]
Loopback Interface hochfahren:                             [  OK  ]
Interface brickxmp hochfahren:                             [  OK  ]
Interface eth0 hochfahren:                                 [  OK  ]
Interface eth1 hochfahren:                                 [  OK  ]

If I rename /etc/sysconfig/network-scripts/ifcfg-brickxmp in
/etc/sysconfig/network-scripts/ifcfg-ippp0 all works correct.

I see the new version redhat-config-network-1.2.13-1 from yesterday.
Same problems I specified in redhat-config-network-1.2.12-1.
Comment 5 Frank Schmitt 2003-07-04 09:02:02 EDT
I see the same problems (with RH 9.0 release, I can't activate my (ISA, non-PNP) 
Fritz-Card, with 1.2.13-1 there's the ifcfg-providername (in my case 
ifcfg-rzonline) problem.

Now that I changed it to ifcfg-ippp0 everything seems to be fine.
Comment 6 Kris 2003-08-10 08:44:19 EDT
This bug still exists in the new beta "Severn".
Could you please fix that problem until the final release ??

Redhat has a lot of customers in Germany and if you want to get more, you should
pay more attention to the ISDN Standard in Germany.
Otherwise you won`t reach Suse...
Comment 7 Kris 2003-08-10 08:46:13 EDT
Ich habe noch etwas vergessen, nach jedem Neustart muß ich die Karte neu
aktivieren, das kann doch auch nicht richtig sein.

Ich nutze derzeit "Severn".

Wäre toll, wenn Du mir mal einen Rat geben könntest.

Note You need to log in before you can comment on or make changes to this bug.