Bug 91612 - "Include conf.d/*.conf" before DSO LoadModules's creates dependency problem
Summary: "Include conf.d/*.conf" before DSO LoadModules's creates dependency problem
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-httpd   
(Show other bugs)
Version: 9
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-26 01:25 UTC by Corey Barcus
Modified: 2015-03-05 01:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-01 16:34:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Corey Barcus 2003-05-26 01:25:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030509

Description of problem:
The Include directive in /etc/httpd/conf/httpd.conf creates a dependency problem
as it comes before the DSO LoadModule section. An example is that the Subversion
module (mod_dav_svn.so) depends on the mod_dav.so module. The Include directive
will attempt to load the subversion.conf file which loads the mod_dav_svn.so
module before the mod_dav.so module. Since mod_dav_svn.so will not load, the
server will not start.

This problem can be easily solved by moving the Include directive after the DSO
LoadModule section.

Version-Release number of selected component (if applicable):
redhat-config-httpd-1.0.1-18

How reproducible:
Always

Steps to Reproduce:
1. See above
2.
3.
    

Additional info:

Comment 1 Phil Knirsch 2003-08-01 16:34:15 UTC
Erh, i think thats a default apache config problem, not a problem with the
redhat-config-httpd tool in general. :-)

I just checked the default httpd.conf file of our latest httpd package and
voila, there it is. I'll fix the output of redhat-config-httpd, too, to reflect
that change.

Fix is in CVS, will be in the next build.

Thanks,

Read ya, Phil


Note You need to log in before you can comment on or make changes to this bug.