Bug 91613 - ATI Radeon Mobility M6 Lightning problems?
Summary: ATI Radeon Mobility M6 Lightning problems?
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 9
Hardware: i686 Linux
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
Keywords: MoveUpstream
Depends On:
TreeView+ depends on / blocked
Reported: 2003-05-26 01:46 UTC by Need Real Name
Modified: 2007-04-18 16:54 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-07-17 10:42:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
X Server Configuration for Radeon Mobility M6 (3.23 KB, text/plain)
2003-05-26 01:48 UTC, Need Real Name
no flags Details
Log file for X server (29.65 KB, text/plain)
2003-05-26 01:49 UTC, Need Real Name
no flags Details

Description Need Real Name 2003-05-26 01:46:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
Whenever I start Quake 3 Arena I observe that textures are not drawn properly.
Instead of seeing a solid textured surface I get random black areas which
depending on the movement, they get intermittently drawn or not. However if I
select under the configuration screen (setup - system -lightning) to change the
lightning technique from lightmap to vertex, I get the game running without
these black areas appearing, but with a lower quality. I tried rebuilding the
XFree86 server from factory source RPMS, but I still get the same problem.
The problem appeared only under RedHat 9, however under RedHat Linux 8 and
XFree86 4.2 the driver works perfectly rendering the textures as expected.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install and run Quake 3 Arena Point Release 1.31 or 1.32.

Actual Results:  The Radeon driver draws intermittent textured and black areas.

Expected Results:  Proper texture rendering and lightning.

Additional info:

Additionally, the computer is a Toshiba Satellite 1905-s301, 2.0 GHz Pentium 4,
256 MB RAM. I am attaching my XFree86 configuration, as well as the last log
output to /var/log/XFree86.0.log

The card as detected by lspci follows:
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M6 LY
(prog-if 00 [VGA])
        Subsystem: Toshiba America Info Systems: Unknown device ff00
        Flags: bus master, stepping, fast Back2Back, 66Mhz, medium devsel,
latency 66, IRQ 5
        Memory at f0000000 (32-bit, prefetchable) [size=128M]
        I/O ports at 3000 [size=256]
        Memory at e8000000 (32-bit, non-prefetchable) [size=64K]
        Expansion ROM at <unassigned> [disabled] [size=128K]
        Capabilities: [58] AGP version 2.0
        Capabilities: [50] Power Management version 2

Comment 1 Need Real Name 2003-05-26 01:48:27 UTC
Created attachment 91961 [details]
X Server Configuration for Radeon Mobility M6

Comment 2 Need Real Name 2003-05-26 01:49:20 UTC
Created attachment 91962 [details]
Log file for X server

Comment 3 Mike A. Harris 2003-05-26 14:58:18 UTC
Please report this problem directly to the Mesa3D project upstream or
the dri-devel mailing list.  You can also file it in XFree86 bugzilla if
you wish, and I will track the upstream progress on this problem and
consider including any fixes they make.

If you'd like me to track the upstream bug report, include the URL here
after filing the bug:  http://bugs.xfree86.org


Comment 4 Mike A. Harris 2003-07-17 10:41:57 UTC
I'm processing UPSTREAM flagged bug reports for upstream fixes currently, and
noticed that this bug was flagged upstream but has no upstream bug URL, and I
was unable to find an upstream bug report of this issue in XFree86 bugzilla
located at:


Closing bug report as WONTFIX as I'm unable to track upstream until a bug
report has been filed upstream, and the URL provided for tracking.  If this
issue is still relevant in the latest XFree86 packages in rawhide, after
reporting upstream at http://bugs.xfree86.org, feel free to add the bug
report URL to this report and reopen if you'd like the issue to be tracked
and any fixes from upstream investigated for inclusion in future Red Hat
XFree86 updates.

Note You need to log in before you can comment on or make changes to this bug.