Bug 91616 - update of kernel to 2.4.20-13.8 caused system hangup and network problems
update of kernel to 2.4.20-13.8 caused system hangup and network problems
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-25 23:23 EDT by David Curry
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-04 14:23:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Curry 2003-05-25 23:23:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Used up2date agent to update kernel from version 2.4.18-14 to version
2.4.20-13.8.  On completion of the update process, up2date agent recommended
that I reboot system and verify that system operated properly.

On reboot, internet connection was no longer viable and Network Device Control
utility was unable to activate ethernet links.  Also, leaving the system idle
without keyboard or mouse activity for several minutes resulted in a blanked
screen that would not reactivate.  Thus, as installed by up2date agent, use of
kernel 2.4.20-13.8 apparently results in lock out of mouse and keyboard, loss of
video, or lock out of keyboard, mouse, and video. Found it necessary to risk
file system integrity and turn off system power to recover (but applied
ctrl-alt-del keystrokes and waited a bit before turning off system power). 

Internet connections were re-established by reversion to kernel version
2.4.18-14.  Subsequent attempts to use kernel 2.4.20-13.8 continued to produce
the blank screen/lockout effects described above. 

Version-Release number of selected component (if applicable):
kernel 2.4.20-13.8

How reproducible:
Always

Steps to Reproduce:
1. Boot the system using kernel version 2.4.20-13.8
2. Abstain from use of the mouse or keyboard for several minutes (precise number
has not been determined at time of this report)
3. Try to "wake" the system using the mouse or board.
    

Actual Results:  Described in the expanded summary above. I will not use the
kernel again unless and until a workaround is identified or bug fix implemented. 

Expected Results:  Expected system to respond with visual display of desktop and
cursor and/or foreground application window.

Additional info:
Comment 1 Adrian Likins 2005-10-04 14:23:39 EDT
This is not a bug with the update agent, but the kernel. If the issue is still
reoccuring, please file a bug against the os product and the kernel component.

Note You need to log in before you can comment on or make changes to this bug.