Bug 916227 - Corosync ignore sigint (and other signals) if exit is requested before full initialization
Summary: Corosync ignore sigint (and other signals) if exit is requested before full i...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: corosync
Version: 6.4
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Jan Friesse
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-02-27 15:11 UTC by Jan Friesse
Modified: 2013-11-21 04:33 UTC (History)
4 users (show)

Fixed In Version: corosync-1.4.1-16.el6
Doc Type: Bug Fix
Doc Text:
Cause: Corosync is exited before full initialization. Consequence: Corosync will never exit and ignore signals (of course with exception of KILL) Fix: Move semaphore initialization. Result: Corosync will properly exit
Clone Of:
Environment:
Last Closed: 2013-11-21 04:33:02 UTC


Attachments (Terms of Use)
Proposed patch (1.79 KB, patch)
2013-02-27 15:11 UTC, Jan Friesse
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1531 normal SHIPPED_LIVE corosync bug fix and enhancement update 2013-11-21 00:40:57 UTC

Description Jan Friesse 2013-02-27 15:11:11 UTC
Created attachment 703488 [details]
Proposed patch

Description of problem:
When corosync receive exit (INT) signal before full initialization, it may happen that corosync will never exit.

Version-Release number of selected component (if applicable):
Flatiron

How reproducible:
100%

Steps to Reproduce:
1. Replace corosync config file by pipe
2. Send INT to corosync process
3. Push corosync config file to pipe (by cat for example)

Actual results:
Corosync will not exit

Expected results:
Corosync will exit

Additional info:
"Unit" test https://github.com/jfriesse/csts/commit/eb0067ba0b2f6b232e7009c750ea49eece6b277a

Comment 8 Jaroslav Kortus 2013-09-11 16:08:43 UTC
Verified with quit-before-full-start.sh

FAIL on corosync-1.4.1-15.el6.x86_64 (RHEL6.4)
PASS on corosync-1.4.1-17.el6.x86_64 (RHEL6.5)

Comment 10 errata-xmlrpc 2013-11-21 04:33:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1531.html


Note You need to log in before you can comment on or make changes to this bug.