Bug 916436 - Review Request: python-narcissus-app - WSGI components for Narcissus, realtime log visualization
Summary: Review Request: python-narcissus-app - WSGI components for Narcissus, realtim...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mario Blättermann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On: 916419 916426 916431 916433
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-02-28 04:31 UTC by Ralph Bean
Modified: 2015-01-14 19:37 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2013-08-02 18:07:36 UTC
mario.blaettermann: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)

Description Ralph Bean 2013-02-28 04:31:01 UTC
Spec URL: http://ralph.fedorapeople.org//python-narcissus-app.spec
SRPM URL: http://ralph.fedorapeople.org//python-narcissus-app-0.9.1-1.fc18.src.rpm

Description:
This package contains the wsgi components for narcissus.  Narcissus
is a web application that visualizes web server hits as they happen
in real time.

Features:

 * IP addresses converted to latitude/longitude, then streamed via
   WebSockets to `polymaps <http://polymaps.org/>`_.
 * Realtime graphs of what countries are downloading what content
   with `d3 <http://d3js.org>`_.
 * `Ømq (zeromq) <http://www.zeromq.org/>`_ on the backend.
 * **Fast**.  No polling.

You can see a demo running live at http://narcissus.rc.rit.edu
It is visualizing the logs of http://mirror.rit.edu

Comment 1 Fedora Update System 2013-04-25 19:00:44 UTC
python-tw2-slideymenu-2.2-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-tw2-slideymenu-2.2-1.fc19

Comment 2 Fedora Update System 2013-04-25 19:01:17 UTC
python-tw2-slideymenu-2.2-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/python-tw2-slideymenu-2.2-1.fc18

Comment 3 Fedora Update System 2013-04-25 19:01:46 UTC
python-tw2-slideymenu-2.2-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/python-tw2-slideymenu-2.2-1.fc17

Comment 4 Fedora Update System 2013-04-25 19:02:12 UTC
python-tw2-slideymenu-2.2-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/python-tw2-slideymenu-2.2-1.el6

Comment 5 Fedora Update System 2013-05-14 04:49:28 UTC
python-tw2-slideymenu-2.2-1.fc19 has been pushed to the Fedora 19 stable repository.

Comment 6 Fedora Update System 2013-05-14 17:46:30 UTC
python-tw2-slideymenu-2.2-1.el6 has been pushed to the Fedora EPEL 6 stable repository.

Comment 7 Fedora Update System 2013-05-15 03:25:06 UTC
python-tw2-slideymenu-2.2-1.fc18 has been pushed to the Fedora 18 stable repository.

Comment 8 Fedora Update System 2013-05-15 03:28:12 UTC
python-tw2-slideymenu-2.2-1.fc17 has been pushed to the Fedora 17 stable repository.

Comment 9 Mario Blättermann 2013-07-01 18:31:40 UTC
Scratch build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=5563227

$ rpmlint -i -v *narcissus-app.noarch: I: checking
narcissus-app.noarch: W: spelling-error Summary(en_US) realtime -> mealtime, real time, real-time
The value of this tag appears to be misspelled. Please double-check.

narcissus-app.noarch: W: spelling-error %description -l en_US wsgi -> swig, wigs, newsgirl
The value of this tag appears to be misspelled. Please double-check.

narcissus-app.noarch: W: spelling-error %description -l en_US polymaps -> poly maps, poly-maps, polyps
The value of this tag appears to be misspelled. Please double-check.

narcissus-app.noarch: W: spelling-error %description -l en_US http -> HTTP
The value of this tag appears to be misspelled. Please double-check.

narcissus-app.noarch: W: spelling-error %description -l en_US zeromq -> zero
The value of this tag appears to be misspelled. Please double-check.

narcissus-app.noarch: W: spelling-error %description -l en_US www -> WWW, wow
The value of this tag appears to be misspelled. Please double-check.

narcissus-app.noarch: W: spelling-error %description -l en_US backend -> backed, back end, back-end
The value of this tag appears to be misspelled. Please double-check.

narcissus-app.noarch: W: invalid-license AGPLv3+
The value of the License tag was not recognized.  Known values are: "AAL",
"Abstyles", "Adobe", "ADSL", "AFL", "Afmparse", "AGPLv1", "AGPLv3", "AGPLv3
with exceptions", "AMDPLPA", "AML", "AMPAS BSD", "APAFML", "APSL 2.0", "APSL
2.0+", "ARL", "Artistic 2.0", "Artistic clarified", "ASL 1.0", "ASL 1.0+",
"ASL 1.1", "ASL 1.1+", "ASL 2.0", "ASL 2.0+", "Bahyph", "Barr", "Beerware",
"BeOpen", "Bibtex", "BitTorrent", "Boost", "Borceux", "BSD", "BSD Protection",
"BSD with advertising", "BSD with attribution", "CATOSL", "CC0", "CeCILL",
"CeCILL-B", "CeCILL-C", "CDDL", "CNRI", "Condor", "Copyright only", "CPAL",
"CPL", "Crossword", "Crystal Stacker", "Cube", "diffmark", "DOC", "Dotseqn",
"DSDP", "dvipdfm", "ECL 1.0", "ECL 2.0", "eCos", "EFL 2.0", "EFL 2.0+",
"eGenix", "Entessa", "EPL", "ERPL", "EU Datagrid", "EUPL 1.1", "Eurosym",
"Fair", "FSFUL", "FSFULLR", "FTL", "Giftware", "GL2PS", "Glide", "Glulxe",
"gnuplot", "GPL+", "GPL+ or Artistic", "GPL+ with exceptions", "GPLv1", "GPLv2
or Artistic", "GPLv2+ or Artistic", "GPLv2", "GPLv2 with exceptions",
"GPLv2+", "GPLv2+ with exceptions", "GPLv3", "GPLv3 with exceptions",
"GPLv3+", "GPLv3+ with exceptions", "HaskellReport", "IBM", "IJG",
"ImageMagick", "iMatix", "Imlib2", "Intel ACPI", "Interbase", "ISC", "Jabber",
"JasPer", "JPython", "Julius", "Knuth", "Latex2e", "LBNL BSD", "Leptonica",
"LGPLv2", "LGPLv2 with exceptions", "LGPLv2+", "LGPLv2+ or Artistic", "LGPLv2+
with exceptions", "LGPLv3", "LGPLv3 with exceptions", "LGPLv3+", "LGPLv3+ with
exceptions", "Lhcyr", "libtiff", "LLGPL", "Logica", "LPL", "LPPL",
"MakeIndex", "mecab-ipadic", "midnight", "MirOS", "MIT", "MITNFA", "MIT with
advertising", "mod_macro", "Motosoto", "MPLv1.0", "MPLv1.0+", "MPLv1.1",
"MPLv1.1+", "MPLv2.0", "MS-PL", "MS-RL", "MTLL", "Mup", "Naumen", "NCSA",
"NetCDF", "Netscape", "Newmat", "Newsletr", "NGPL", "NLPL", "Nokia", "NOSL",
"Noweb", "OML", "OpenLDAP", "OpenPBS", "OpenSSL", "OReilly", "OSL 1.0", "OSL
1.0+", "OSL 1.1", "OSL 1.1+", "OSL 2.0", "OSL 2.0+", "OSL 2.1", "OSL 2.1+",
"OSL 3.0", "OSL 3.0+", "Par", "Phorum", "PHP", "PlainTeX", "Plexus",
"PostgreSQL", "psfrag", "psutils", "Public Domain", "Python", "Qhull", "QPL",
"Rdisc", "RiceBSD", "Romio", "RPSL", "Rsfs", "Ruby", "Saxpath", "SCEA",
"SCRIP", "Sendmail", "Sleepycat", "SISSL", "SLIB", "SNIA", "softSurfer",
"SPL", "STMPL", "SWL", "TCL", "Teeworlds", "Threeparttable", "TMate",
"TORQUEv1.1", "TOSL", "TPL", "UCD", "Vim", "VNLSL", "VOSTROM", "VSL", "W3C",
"Webmin", "Wsuipa", "WTFPL", "wxWidgets", "Xerox", "xinetd", "xpp", "XSkat",
"YPLv1.1", "Zed", "Zend", "zlib", "zlib with acknowledgement", "ZPLv1.0",
"ZPLv1.0+", "ZPLv2.0", "ZPLv2.0+", "ZPLv2.1", "ZPLv2.1+", "CDL", "FBSDDL",
"GFDL", "IEEE", "LDPL", "OFSFDL", "Open Publication", "Public Use",
"Verbatim", "CC-BY", "CC-BY-ND", "CC-BY-SA", "DMTF", "DSL", "EFML", "Free
Art", "GeoGratis", "Green OpenMusic", "OAL", "AMS", "Arphic", "Baekmuk",
"Bitstream Vera", "DoubleStroke", "Hershey", "IPA", "Liberation", "Lucida",
"MgOpen", "mplus", "OFL", "PTFL", "STIX", "Utopia", "Wadalab", "XANO",
"Redistributable, no modification permitted", "Freely redistributable without
restriction".

narcissus-app.noarch: I: checking-url http://pypi.python.org/pypi/narcissus.app (timeout 10 seconds)
narcissus-app.noarch: W: no-documentation
The package contains no documentation (README, doc, etc). You have to include
documentation files.

python-narcissus-app.src: I: checking
python-narcissus-app.src: W: spelling-error Summary(en_US) realtime -> mealtime, real time, real-time
The value of this tag appears to be misspelled. Please double-check.

python-narcissus-app.src: W: spelling-error %description -l en_US wsgi -> swig, wigs, newsgirl
The value of this tag appears to be misspelled. Please double-check.

python-narcissus-app.src: W: spelling-error %description -l en_US polymaps -> poly maps, poly-maps, polyps
The value of this tag appears to be misspelled. Please double-check.

python-narcissus-app.src: W: spelling-error %description -l en_US http -> HTTP
The value of this tag appears to be misspelled. Please double-check.

python-narcissus-app.src: W: spelling-error %description -l en_US zeromq -> zero
The value of this tag appears to be misspelled. Please double-check.

python-narcissus-app.src: W: spelling-error %description -l en_US www -> WWW, wow
The value of this tag appears to be misspelled. Please double-check.

python-narcissus-app.src: W: spelling-error %description -l en_US backend -> backed, back end, back-end
The value of this tag appears to be misspelled. Please double-check.

python-narcissus-app.src: W: invalid-license AGPLv3+
The value of the License tag was not recognized.  Known values are: "AAL",
"Abstyles", "Adobe", "ADSL", "AFL", "Afmparse", "AGPLv1", "AGPLv3", "AGPLv3
with exceptions", "AMDPLPA", "AML", "AMPAS BSD", "APAFML", "APSL 2.0", "APSL
2.0+", "ARL", "Artistic 2.0", "Artistic clarified", "ASL 1.0", "ASL 1.0+",
"ASL 1.1", "ASL 1.1+", "ASL 2.0", "ASL 2.0+", "Bahyph", "Barr", "Beerware",
"BeOpen", "Bibtex", "BitTorrent", "Boost", "Borceux", "BSD", "BSD Protection",
"BSD with advertising", "BSD with attribution", "CATOSL", "CC0", "CeCILL",
"CeCILL-B", "CeCILL-C", "CDDL", "CNRI", "Condor", "Copyright only", "CPAL",
"CPL", "Crossword", "Crystal Stacker", "Cube", "diffmark", "DOC", "Dotseqn",
"DSDP", "dvipdfm", "ECL 1.0", "ECL 2.0", "eCos", "EFL 2.0", "EFL 2.0+",
"eGenix", "Entessa", "EPL", "ERPL", "EU Datagrid", "EUPL 1.1", "Eurosym",
"Fair", "FSFUL", "FSFULLR", "FTL", "Giftware", "GL2PS", "Glide", "Glulxe",
"gnuplot", "GPL+", "GPL+ or Artistic", "GPL+ with exceptions", "GPLv1", "GPLv2
or Artistic", "GPLv2+ or Artistic", "GPLv2", "GPLv2 with exceptions",
"GPLv2+", "GPLv2+ with exceptions", "GPLv3", "GPLv3 with exceptions",
"GPLv3+", "GPLv3+ with exceptions", "HaskellReport", "IBM", "IJG",
"ImageMagick", "iMatix", "Imlib2", "Intel ACPI", "Interbase", "ISC", "Jabber",
"JasPer", "JPython", "Julius", "Knuth", "Latex2e", "LBNL BSD", "Leptonica",
"LGPLv2", "LGPLv2 with exceptions", "LGPLv2+", "LGPLv2+ or Artistic", "LGPLv2+
with exceptions", "LGPLv3", "LGPLv3 with exceptions", "LGPLv3+", "LGPLv3+ with
exceptions", "Lhcyr", "libtiff", "LLGPL", "Logica", "LPL", "LPPL",
"MakeIndex", "mecab-ipadic", "midnight", "MirOS", "MIT", "MITNFA", "MIT with
advertising", "mod_macro", "Motosoto", "MPLv1.0", "MPLv1.0+", "MPLv1.1",
"MPLv1.1+", "MPLv2.0", "MS-PL", "MS-RL", "MTLL", "Mup", "Naumen", "NCSA",
"NetCDF", "Netscape", "Newmat", "Newsletr", "NGPL", "NLPL", "Nokia", "NOSL",
"Noweb", "OML", "OpenLDAP", "OpenPBS", "OpenSSL", "OReilly", "OSL 1.0", "OSL
1.0+", "OSL 1.1", "OSL 1.1+", "OSL 2.0", "OSL 2.0+", "OSL 2.1", "OSL 2.1+",
"OSL 3.0", "OSL 3.0+", "Par", "Phorum", "PHP", "PlainTeX", "Plexus",
"PostgreSQL", "psfrag", "psutils", "Public Domain", "Python", "Qhull", "QPL",
"Rdisc", "RiceBSD", "Romio", "RPSL", "Rsfs", "Ruby", "Saxpath", "SCEA",
"SCRIP", "Sendmail", "Sleepycat", "SISSL", "SLIB", "SNIA", "softSurfer",
"SPL", "STMPL", "SWL", "TCL", "Teeworlds", "Threeparttable", "TMate",
"TORQUEv1.1", "TOSL", "TPL", "UCD", "Vim", "VNLSL", "VOSTROM", "VSL", "W3C",
"Webmin", "Wsuipa", "WTFPL", "wxWidgets", "Xerox", "xinetd", "xpp", "XSkat",
"YPLv1.1", "Zed", "Zend", "zlib", "zlib with acknowledgement", "ZPLv1.0",
"ZPLv1.0+", "ZPLv2.0", "ZPLv2.0+", "ZPLv2.1", "ZPLv2.1+", "CDL", "FBSDDL",
"GFDL", "IEEE", "LDPL", "OFSFDL", "Open Publication", "Public Use",
"Verbatim", "CC-BY", "CC-BY-ND", "CC-BY-SA", "DMTF", "DSL", "EFML", "Free
Art", "GeoGratis", "Green OpenMusic", "OAL", "AMS", "Arphic", "Baekmuk",
"Bitstream Vera", "DoubleStroke", "Hershey", "IPA", "Liberation", "Lucida",
"MgOpen", "mplus", "OFL", "PTFL", "STIX", "Utopia", "Wadalab", "XANO",
"Redistributable, no modification permitted", "Freely redistributable without
restriction".

python-narcissus-app.src: I: checking-url http://pypi.python.org/pypi/narcissus.app (timeout 10 seconds)
python-narcissus-app.src: I: checking-url http://pypi.python.org/packages/source/n/narcissus.app/narcissus.app-0.9.1.tar.gz (timeout 10 seconds)
python-narcissus-app.noarch: I: checking
python-narcissus-app.noarch: W: spelling-error Summary(en_US) realtime -> mealtime, real time, real-time
The value of this tag appears to be misspelled. Please double-check.

python-narcissus-app.noarch: W: spelling-error %description -l en_US wsgi -> swig, wigs, newsgirl
The value of this tag appears to be misspelled. Please double-check.

python-narcissus-app.noarch: W: spelling-error %description -l en_US polymaps -> poly maps, poly-maps, polyps
The value of this tag appears to be misspelled. Please double-check.

python-narcissus-app.noarch: W: spelling-error %description -l en_US http -> HTTP
The value of this tag appears to be misspelled. Please double-check.

python-narcissus-app.noarch: W: spelling-error %description -l en_US zeromq -> zero
The value of this tag appears to be misspelled. Please double-check.

python-narcissus-app.noarch: W: spelling-error %description -l en_US www -> WWW, wow
The value of this tag appears to be misspelled. Please double-check.

python-narcissus-app.noarch: W: spelling-error %description -l en_US backend -> backed, back end, back-end
The value of this tag appears to be misspelled. Please double-check.

python-narcissus-app.noarch: W: invalid-license AGPLv3+
The value of the License tag was not recognized.  Known values are: "AAL",
"Abstyles", "Adobe", "ADSL", "AFL", "Afmparse", "AGPLv1", "AGPLv3", "AGPLv3
with exceptions", "AMDPLPA", "AML", "AMPAS BSD", "APAFML", "APSL 2.0", "APSL
2.0+", "ARL", "Artistic 2.0", "Artistic clarified", "ASL 1.0", "ASL 1.0+",
"ASL 1.1", "ASL 1.1+", "ASL 2.0", "ASL 2.0+", "Bahyph", "Barr", "Beerware",
"BeOpen", "Bibtex", "BitTorrent", "Boost", "Borceux", "BSD", "BSD Protection",
"BSD with advertising", "BSD with attribution", "CATOSL", "CC0", "CeCILL",
"CeCILL-B", "CeCILL-C", "CDDL", "CNRI", "Condor", "Copyright only", "CPAL",
"CPL", "Crossword", "Crystal Stacker", "Cube", "diffmark", "DOC", "Dotseqn",
"DSDP", "dvipdfm", "ECL 1.0", "ECL 2.0", "eCos", "EFL 2.0", "EFL 2.0+",
"eGenix", "Entessa", "EPL", "ERPL", "EU Datagrid", "EUPL 1.1", "Eurosym",
"Fair", "FSFUL", "FSFULLR", "FTL", "Giftware", "GL2PS", "Glide", "Glulxe",
"gnuplot", "GPL+", "GPL+ or Artistic", "GPL+ with exceptions", "GPLv1", "GPLv2
or Artistic", "GPLv2+ or Artistic", "GPLv2", "GPLv2 with exceptions",
"GPLv2+", "GPLv2+ with exceptions", "GPLv3", "GPLv3 with exceptions",
"GPLv3+", "GPLv3+ with exceptions", "HaskellReport", "IBM", "IJG",
"ImageMagick", "iMatix", "Imlib2", "Intel ACPI", "Interbase", "ISC", "Jabber",
"JasPer", "JPython", "Julius", "Knuth", "Latex2e", "LBNL BSD", "Leptonica",
"LGPLv2", "LGPLv2 with exceptions", "LGPLv2+", "LGPLv2+ or Artistic", "LGPLv2+
with exceptions", "LGPLv3", "LGPLv3 with exceptions", "LGPLv3+", "LGPLv3+ with
exceptions", "Lhcyr", "libtiff", "LLGPL", "Logica", "LPL", "LPPL",
"MakeIndex", "mecab-ipadic", "midnight", "MirOS", "MIT", "MITNFA", "MIT with
advertising", "mod_macro", "Motosoto", "MPLv1.0", "MPLv1.0+", "MPLv1.1",
"MPLv1.1+", "MPLv2.0", "MS-PL", "MS-RL", "MTLL", "Mup", "Naumen", "NCSA",
"NetCDF", "Netscape", "Newmat", "Newsletr", "NGPL", "NLPL", "Nokia", "NOSL",
"Noweb", "OML", "OpenLDAP", "OpenPBS", "OpenSSL", "OReilly", "OSL 1.0", "OSL
1.0+", "OSL 1.1", "OSL 1.1+", "OSL 2.0", "OSL 2.0+", "OSL 2.1", "OSL 2.1+",
"OSL 3.0", "OSL 3.0+", "Par", "Phorum", "PHP", "PlainTeX", "Plexus",
"PostgreSQL", "psfrag", "psutils", "Public Domain", "Python", "Qhull", "QPL",
"Rdisc", "RiceBSD", "Romio", "RPSL", "Rsfs", "Ruby", "Saxpath", "SCEA",
"SCRIP", "Sendmail", "Sleepycat", "SISSL", "SLIB", "SNIA", "softSurfer",
"SPL", "STMPL", "SWL", "TCL", "Teeworlds", "Threeparttable", "TMate",
"TORQUEv1.1", "TOSL", "TPL", "UCD", "Vim", "VNLSL", "VOSTROM", "VSL", "W3C",
"Webmin", "Wsuipa", "WTFPL", "wxWidgets", "Xerox", "xinetd", "xpp", "XSkat",
"YPLv1.1", "Zed", "Zend", "zlib", "zlib with acknowledgement", "ZPLv1.0",
"ZPLv1.0+", "ZPLv2.0", "ZPLv2.0+", "ZPLv2.1", "ZPLv2.1+", "CDL", "FBSDDL",
"GFDL", "IEEE", "LDPL", "OFSFDL", "Open Publication", "Public Use",
"Verbatim", "CC-BY", "CC-BY-ND", "CC-BY-SA", "DMTF", "DSL", "EFML", "Free
Art", "GeoGratis", "Green OpenMusic", "OAL", "AMS", "Arphic", "Baekmuk",
"Bitstream Vera", "DoubleStroke", "Hershey", "IPA", "Liberation", "Lucida",
"MgOpen", "mplus", "OFL", "PTFL", "STIX", "Utopia", "Wadalab", "XANO",
"Redistributable, no modification permitted", "Freely redistributable without
restriction".

python-narcissus-app.noarch: I: checking-url http://pypi.python.org/pypi/narcissus.app (timeout 10 seconds)
python-narcissus-app.noarch: W: no-manual-page-for-binary narcissus.app-serve
Each executable in standard binary directories should have a man page.

python-narcissus-app.spec: I: checking-url http://pypi.python.org/packages/source/n/narcissus.app/narcissus.app-0.9.1.tar.gz (timeout 10 seconds)
3 packages and 1 specfiles checked; 0 errors, 26 warnings.



Ignorable spelling errors, no manpages, not up to you to fix. The license is OK, although it is not mentioned in the licensing guidelines. We have there AGPLv3 only.

$ licensecheck -r *
narcissus/app/widgets/__init__.py: *No copyright* UNKNOWN
narcissus/app/routes.py: *No copyright* UNKNOWN
narcissus/app/__init__.py: AGPL (v3 or later)
narcissus/__init__.py: *No copyright* UNKNOWN
setup.py: AGPL (v3 or later)

This way we get AGPLv3+, of course.



---------------------------------
key:

[+] OK
[.] OK, not applicable
[X] needs work
---------------------------------

[+] MUST: rpmlint must be run on the source rpm and all binary rpms the build produces. The output should be posted in the review.
[+] MUST: The package must be named according to the Package Naming Guidelines.
[+] MUST: The spec file name must match the base package %{name}, in the format %{name}.spec unless your package has an exemption.
[+] MUST: The package must meet the Packaging Guidelines.
[+] MUST: The package must be licensed with a Fedora approved license and meet the Licensing Guidelines.
[+] MUST: The License field in the package spec file must match the actual license.
    AGPLv3+
[+] MUST: If (and only if) the source package includes the text of the license(s) in its own file, then that file, containing the text of the license(s) for the package must be included in %doc.
[+] MUST: The spec file must be written in American English.
[+] MUST: The spec file for the package MUST be legible.
[+] MUST: The sources used to build the package must match the upstream source, as provided in the spec URL. Reviewers should use sha256sum for this task as it is used by the sources file once imported into git. If no upstream URL can be specified for this package, please see the Source URL Guidelines for how to deal with this.
    $ sha256sum *
    1a3905b5cc095b3963cc90a66e23eabce476f6809fbe03aae7175792755af163  narcissus.app-0.9.1.tar.gz
    1a3905b5cc095b3963cc90a66e23eabce476f6809fbe03aae7175792755af163  narcissus.app-0.9.1.tar.gz.packaged

[+] MUST: The package MUST successfully compile and build into binary rpms on at least one primary architecture.
[.] MUST: If the package does not successfully compile, build or work on an architecture, then those architectures should be listed in the spec in ExcludeArch. Each architecture listed in ExcludeArch MUST have a bug filed in bugzilla, describing the reason that the package does not compile/build/work on that architecture. The bug number MUST be placed in a comment, next to the corresponding ExcludeArch line.
[+] MUST: All build dependencies must be listed in BuildRequires, except for any that are listed in the exceptions section of the Packaging Guidelines ; inclusion of those as BuildRequires is optional. Apply common sense.
[.] MUST: The spec file MUST handle locales properly. This is done by using the %find_lang macro. Using %{_datadir}/locale/* is strictly forbidden.
[.] MUST: Every binary RPM package (or subpackage) which stores shared library files (not just symlinks) in any of the dynamic linker's default paths, must call ldconfig in %post and %postun.
[.] MUST: Packages must NOT bundle copies of system libraries.
[.] MUST: If the package is designed to be relocatable, the packager must state this fact in the request for review, along with the rationalization for relocation of that specific package. Without this, use of Prefix: /usr is considered a blocker.
[+] MUST: A package must own all directories that it creates. If it does not create a directory that it uses, then it should require a package which does create that directory.
[+] MUST: A Fedora package must not list a file more than once in the spec file's %files listings. (Notable exception: license texts in specific situations)
[+] MUST: Permissions on files must be set properly. Executables should be set with executable permissions, for example.
[+] MUST: Each package must consistently use macros.
[+] MUST: The package must contain code, or permissable content.
[.] MUST: Large documentation files must go in a -doc subpackage. (The definition of large is left up to the packager's best judgement, but is not restricted to size. Large can refer to either size or quantity).
[+] MUST: If a package includes something as %doc, it must not affect the runtime of the application. To summarize: If it is in %doc, the program must run properly if it is not present.
[.] MUST: Static libraries must be in a -static package.
[.] MUST: Development files must be in a -devel package.
[.] MUST: In the vast majority of cases, devel packages must require the base package using a fully versioned dependency: Requires: %{name}%{?_isa} = %{version}-%{release}
[.] MUST: Packages must NOT contain any .la libtool archives, these must be removed in the spec if they are built.
[.] MUST: Packages containing GUI applications must include a %{name}.desktop file, and that file must be properly installed with desktop-file-install in the %install section. If you feel that your packaged GUI application does not need a .desktop file, you must put a comment in the spec file with your explanation.
[+] MUST: Packages must not own files or directories already owned by other packages. The rule of thumb here is that the first package to be installed should own the files or directories that other packages may rely upon. This means, for example, that no package in Fedora should ever share ownership with any of the files or directories owned by the filesystem or man package. If you feel that you have a good reason to own a file or directory that another package owns, then please present that at package review time. 
[+] MUST: All filenames in rpm packages must be valid UTF-8.


[.] SHOULD: If the source package does not include license text(s) as a separate file from upstream, the packager SHOULD query upstream to include it.
[.] SHOULD: The description and summary sections in the package spec file should contain translations for supported Non-English languages, if available.
[+] SHOULD: The reviewer should test that the package builds in mock.
    See Koji build above (which uses Mock anyway).
[+] SHOULD: The package should compile and build into binary rpms on all supported architectures.
[.] SHOULD: The reviewer should test that the package functions as described. A package should not segfault instead of running, for example.
[+] SHOULD: If scriptlets are used, those scriptlets must be sane. This is vague, and left up to the reviewers judgement to determine sanity.
[.] SHOULD: Usually, subpackages other than devel should require the base package using a fully versioned dependency.
[.] SHOULD: The placement of pkgconfig(.pc) files depends on their usecase, and this is usually for development purposes, so should be placed in a -devel pkg. A reasonable exception is that the main pkg itself is a devel tool not installed in a user runtime, e.g. gcc or gdb.
[.] SHOULD: If the package has file dependencies outside of /etc, /bin, /sbin, /usr/bin, or /usr/sbin consider requiring the package which provides the file instead of the file itself.
[.] SHOULD: your package should contain man pages for binaries/scripts. If it doesn't, work with upstream to add them where they make sense.


----------------

PACKAGE APPROVED

----------------

Comment 10 Ralph Bean 2013-07-01 19:56:52 UTC
New Package SCM Request
=======================
Package Name: python-narcissus-app
Short Description: WSGI components for Narcissus, realtime log visualization
Owners: ralph
Branches: f19 f18 el6
InitialCC:

Comment 11 Ralph Bean 2013-07-01 19:58:40 UTC
Thanks Mario!

Comment 12 Gwyn Ciesla 2013-07-01 20:17:46 UTC
Git done (by process-git-requests).

Comment 13 Fedora Update System 2013-07-02 00:07:35 UTC
python-narcissus-app-0.9.1-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-narcissus-app-0.9.1-1.fc19

Comment 14 Fedora Update System 2013-07-02 00:07:53 UTC
python-narcissus-app-0.9.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/python-narcissus-app-0.9.1-1.fc18

Comment 15 Fedora Update System 2013-07-02 00:08:10 UTC
python-narcissus-app-0.9.1-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/python-narcissus-app-0.9.1-1.el6

Comment 16 Fedora Update System 2013-07-30 17:42:32 UTC
python-narcissus-app-0.9.1-1.fc18 has been pushed to the Fedora 18 stable repository.

Comment 17 Fedora Update System 2013-07-30 17:43:20 UTC
python-narcissus-app-0.9.1-1.fc19 has been pushed to the Fedora 19 stable repository.

Comment 18 Fedora Update System 2013-08-01 20:35:10 UTC
python-narcissus-app-0.9.1-1.el6 has been pushed to the Fedora EPEL 6 stable repository.

Comment 19 Mario Blättermann 2013-08-02 18:07:36 UTC
All packages for the requested Git branches are now in the stable repositories, so I'll close this ticket now.

Comment 20 Ralph Bean 2013-08-03 11:06:42 UTC
Thanks Mario!

Comment 21 Ralph Bean 2015-01-14 16:33:01 UTC
Package Change Request
======================
Package Name: python-narcissus-app
New Branches: epel7
Owners: ralph

Comment 22 Gwyn Ciesla 2015-01-14 19:37:23 UTC
Git done (by process-git-requests).


Note You need to log in before you can comment on or make changes to this bug.