Bug 91646 - Spaces for Periods in Arial-like fonts
Spaces for Periods in Arial-like fonts
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: mozilla (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
Ben Levenson
http://sikpigs.net/images/notice-no-p...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-26 14:41 EDT by Rob Lake
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-08 14:08:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rob Lake 2003-05-26 14:41:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
Using arial font in applications like mozilla and gnome-terminal displays spaces
for period and apostrophes.  Currently using WindowMaker, but problem exists in
GNOME as well.  Re-installed all font packages on system and restarted xfs with
no success.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start mozilla or gnome-terminal
2. Type '.' or '''
3. profit?
    

Additional info:
Comment 1 Mike A. Harris 2003-05-27 02:25:16 EDT
This has nothing to do with XFree86.
Comment 2 Mike A. Harris 2003-05-27 03:09:38 EDT
As an additional datapoint, GNOME doesn't use xfs.
Comment 3 Rob Lake 2003-05-27 15:04:19 EDT
Here are some examples with arial font not behaving in GNOME terminal, running
in GNOME not WindowMaker.  Mozilla in bug URL is running in WindowMaker but
exhibits the same problem in GNOME.

http://sikpigs.net/images/gnome-terminal-not-arial.jpg
http://sikpigs.net/images/gnome-terminal-arial.jpg

I also tried using arial font in The GIMP and there is no period, comma,
aposthrophe, semi-colon, etc.

Perhaps this is problem with ttfonts rather than mozilla or XFree86.
Comment 4 Christopher Blizzard 2003-06-02 11:02:13 EDT
It's probably not Mozilla-specific, no.  Over to Owen.
Comment 5 Owen Taylor 2003-06-02 11:21:12 EDT
What version of Arial exactly?

On my system with a Windows XP partition, I don't seem to see this.
Comment 6 Rob Lake 2003-06-03 14:13:04 EDT
Recently I found that by commenting the <dir>/usr/share/fonts</dir> line in
/etc/fonts/fonts.conf, the problem no longer exists.  I would love to tell what
version of Arial it is, but would require a pointer.  In /etc/fonts/fonts.conf,
Arial, Verdana, Helvetica, etc. are aliases for the sans-serif family.  Using
Verdana or Helvetica fonts also produces the problem, which may or may not help
to determine the problem.
Comment 7 Owen Taylor 2003-08-29 11:29:01 EDT
A good way of telling what fonts an app are using is to look at
/proc/<pid>/maps, since each font will be memory-mapped.

The GUI font in your screenshot looks like the Red Hat standard
Luxi Sans, so whatever other font is open would be the font that
it is using. Mozilla screenshots would really be more useful,
since using a proportionally spaced font like Arial in a terminal
widget is expected to give bad rendering (see the overlapping
@ signs, etc.)
Comment 8 Rob Lake 2003-10-06 08:37:55 EDT
Here is another Mozilla screenshot:
http://sikpigs.net/images/mozilla-font-prob.jpg

This is the map file from the Mozilla proc:
41f52000-41f56000 r--p 00000000 03:03 738888    
/usr/X11R6/lib/X11/fonts/100dpi/helvR08.pcf.gz
43d98000-43da1000 r--p 00000000 03:03 2561404   
/usr/share/fonts/ISO8859-2/Type1/ariam___.pfb
43dad000-43dc0000 r--p 00000000 03:03 1920823   
/usr/X11R6/lib/X11/fonts/Type1/l047013t.pfa
44dd4000-44de6000 r--p 00000000 03:03 1920833   
/usr/X11R6/lib/X11/fonts/Type1/l048016t.pfa
45032000-4503b000 r--p 00000000 03:03 2561402   
/usr/share/fonts/ISO8859-2/Type1/ariabi__.pfb
4503b000-45056000 r--p 00000000 03:03 1132854   
/usr/share/fonts/default/Type1/n021003l.pfb

And this from gnome-terminal proc (using Arial):
40fad000-40faf000 r--p 00000000 03:03 738891    
/usr/X11R6/lib/X11/fonts/100dpi/helvR12-ISO8859-1.pcf.gz
40fb1000-40fc3000 r--p 00000000 03:03 1920831   
/usr/X11R6/lib/X11/fonts/Type1/l048013t.pfa
40fc3000-40fd6000 r--p 00000000 03:03 1920823   
/usr/X11R6/lib/X11/fonts/Type1/l047013t.pfa
40fe1000-40ff3000 r--p 00000000 03:03 1920833   
/usr/X11R6/lib/X11/fonts/Type1/l048016t.pfa
40ff3000-41005000 r--p 00000000 03:03 1920835   
/usr/X11R6/lib/X11/fonts/Type1/l048033t.pfa
41005000-4100e000 r--p 00000000 03:03 2561401   
/usr/share/fonts/ISO8859-2/Type1/ariab___.pfb
Comment 9 Owen Taylor 2003-10-06 12:36:52 EDT
Can you attach your fonts.conf? Have you made any local modifications to 
it or created a ~/.fonts.conf? 

/usr/X11R6/lib/X11/fonts/100dpi/ is not supposed to be in the list
of directories for the Red Hat configuration.
Comment 10 Owen Taylor 2004-11-08 14:08:58 EST
No information, closing.

Note You need to log in before you can comment on or make changes to this bug.