Bug 91649 - static rpm
Summary: static rpm
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-26 18:57 UTC by acount closed by user
Modified: 2007-03-27 04:04 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-27 17:58:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description acount closed by user 2003-05-26 18:57:28 UTC
Description of problem:

I would like to have a rpm.static binary for emergencies. is this possible?

-thanks-

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:

Comment 1 Jeff Johnson 2003-05-27 17:58:06 UTC
rpm behavior depends on what kernel is booted and what glibc
is installed, so statically linking /bin/rpm is no longer viable.

For example, there is already in rpm-4.2 a statically linked
/usr/lib/rpm/rpmi, segfaults because of various NPTL/TLS runtime
incompatibilities.


Note You need to log in before you can comment on or make changes to this bug.