Bug 91655 - gnome-panel selected color defaults to black on reboot
Summary: gnome-panel selected color defaults to black on reboot
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-panel   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact:
URL:
Whiteboard:
Keywords: MoveUpstream, Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-26 20:32 UTC by dfowensby
Modified: 2007-04-18 16:54 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-27 15:50:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch from recent gnome-panel sources (422 bytes, text/plain)
2003-09-10 20:14 UTC, Lynn Kerby
no flags Details

Description dfowensby 2003-05-26 20:32:56 UTC
Description of problem:user gnome-panel color reverts to black, if preference of
color is selected.


Version-Release number of selected component (if applicable):rh9 (updated 20030526).


How reproducible: login as user. right click gnome-panel, properties,
background, type, color (choose your favorite from the color palette/round
thingy), close, reboot, login. black is now your favorite color, whether you
like it or not.


Steps to Reproduce:
1.reselect default panel color (defaults to gray).
2.reboot.
3.reselect your favorite panel color (defaults to black on next login)
    
Actual results:selected color defaults to black. this also is reproducable when
attempting to use transparent mode--panel color will default to black on next
login. havent tried it using pixmap.


Expected results: panel should remain cobalt blue, not black.


Additional info:compare diff to rh8 panel properties code. this may be a line or
letter omission/misspell problem

Comment 1 Havoc Pennington 2003-08-07 20:37:01 UTC
This is probably fixed in rawhide, but should have a look.

Comment 2 Lynn Kerby 2003-09-10 18:42:14 UTC
This bug is apparently present in all gnome 2.2 desktops.

See http://bugzilla.gnome.org/show_bug.cgi?id=115692

Comment 3 Lynn Kerby 2003-09-10 20:14:55 UTC
Created attachment 94388 [details]
patch from recent gnome-panel sources

Turns out this is fixed in the newer gnome-panel sources.  I downloaded the
gnome-panel-2.2.2.2 sources from gnome.org and came up with the attached patch.


I realize that developers don't see this as a critical fix, but IMO it can
be a real turn-off for potential new users.

Comment 4 Mark McLoughlin 2004-02-27 15:50:57 UTC
Definitely fixed in Fedora Core 1


Note You need to log in before you can comment on or make changes to this bug.