Bug 916597 - Misleading error message: Network error: Connection reset by peer
Summary: Misleading error message: Network error: Connection reset by peer
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: yum-rhn-plugin
Version: 6.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Matej Kollar
QA Contact: Pavel Studeník
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-02-28 12:46 UTC by Graham Leggett
Modified: 2015-07-22 07:25 UTC (History)
6 users (show)

Fixed In Version: rhn-client-tools-1.0.0.1-23-el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-22 07:25:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1390 normal SHIPPED_LIVE yum-rhn-plugin bug fix and enhancement update 2015-07-20 17:58:08 UTC

Description Graham Leggett 2013-02-28 12:46:46 UTC
When an attempt is made to run a yum update, the error below is reported.

Obviously, a network connection is failing, however there are 6 yum repos that could have failed in this case, and the error message does not indicate the URL it was trying to fetch.

As a result the administrator does not have a clear and unambiguous cause of the error, and needs to check all 6.

Please include the URL in the error message.

[root@tools02 certs]# yum update
Failed to set locale, defaulting to C
Loaded plugins: product-id, rhnplugin, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.


Network error: Connection reset by peer

Comment 2 RHEL Product and Program Management 2013-03-04 06:47:34 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 3 James Antill 2013-04-09 21:00:20 UTC
Does this still happen with --noplugins? I wouldn't be shocked if this was an error from the rhnplugin, if it does can you change the command to:

ULRGRABBER_DEBUG=1 yum -d9 update

...to get more data.

Comment 4 Bryan Totty 2013-08-12 14:36:20 UTC
I have two systems that display this error message. Running with the "--noplugins" bypasses the error message and causes the command to succeed.

Comment 5 Valentina Mukhamedzhanova 2014-03-26 09:09:32 UTC
Since the problem is caused by the plugin, changing the component.

Comment 6 Matej Kollar 2015-02-13 17:21:01 UTC
More precise reproducer of very similar bug:

make sure that hostname of RHN/Satellite/Spacewalk gets resolved to address you have under control (e.g. set hostname  localhost in /etc/hosts) and on that machine run

    nc -l 443 >/dev/full

(make sure serverURL in /etc/sysconfig/rhn/up2date use https protocol) then run

    yum repolist

and you will get

    Loaded plugins: product-id, rhnplugin, security, subscription-manager
    
    
    Network error: ssl handshake failure

Comment 7 Matej Kollar 2015-02-16 10:28:33 UTC
The network error is not connected to any particular repository -- it is caused when communicating with RHN/Satellite/Spacewalk. I propose changing error message to the following:

rhn-plugin: Network error: Connection reset by peer

Thus pointing out to configuration of rhnplugin narrowing the possibilities.

Would this be ok?

Comment 8 Matej Kollar 2015-02-16 12:59:08 UTC
You can see proposed change here: https://github.com/xkollar/spacewalk/compare/Bz916597

Comment 9 Matej Kollar 2015-02-17 21:25:29 UTC
Upstream work
Spacewalk.git: f21a1d00d0ceeb519bcb6f04e1258b1bd2ecbe0a

Comment 12 Pavel Studeník 2015-03-10 13:16:47 UTC
Verified with rhn-client-tools-1.0.0.1-23.el6.noarch.rpm

# yum repolist
Loaded plugins: product-id, rhnplugin, security, subscription-manager


rhn-plugin: Network error: unknown protocol

Comment 13 errata-xmlrpc 2015-07-22 07:25:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1390.html


Note You need to log in before you can comment on or make changes to this bug.