This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 916657 - dnf remove wants to downgrade packages; fails on transaction check
dnf remove wants to downgrade packages; fails on transaction check
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-28 10:54 EST by Rahul Sundaram
Modified: 2014-09-30 19:41 EDT (History)
2 users (show)

See Also:
Fixed In Version: dnf-0.3.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-14 04:52:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rahul Sundaram 2013-02-28 10:54:55 EST
Description of problem:

[rahul@localhost ~]$ sudo dnf remove *-devel
dSetting up Remove Process
Resolving Dependencies
--> Starting dependency resolution
--> Finding unneeded leftover dependencies
---> Package perl-ExtUtils-Manifest.noarch 1.61-239.fc18 will be downgraded
---> Package perl-ExtUtils-Manifest.noarch 1.60-3.fc18 will be a downgrade
---> Package setroubleshoot.x86_64 3.1.19-3.fc18 will be downgraded
---> Package setroubleshoot.x86_64 3.1.18-1.fc18 will be a downgrade
---> Package setroubleshoot-server.x86_64 3.1.19-3.fc18 will be downgraded
---> Package setroubleshoot-server.x86_64 3.1.18-1.fc18 will be a downgrade
---> Package DevIL-devel.x86_64 1.7.8-10.fc18 will be erased
---> Package GeoIP-devel.x86_64 1.4.8-4.fc18 will be erased
---> Package Hermes-devel.x86_64 1.3.3-20.fc18 will be erased
---> Package LibRaw-devel.x86_64 0.14.6-3.fc18 will be erased
---> Package aiksaurus-devel.x86_64 1:1.2.1-26.fc18 will be erased
---> Package alsa-lib-devel.x86_64 1.0.26-2.fc18 will be erased
---> Package ant.noarch 1.8.4-5.fc18 will be erased
---> Package ant-antlr.noarch 1.8.4-5.fc18 will be erased
---> Package ant-apache-bcel.noarch 1.8.4-5.fc18 will be erased
---> Package ant-apache-bsf.noarch 1.8.4-5.fc18 will be erased
---> Package ant-apache-log4j.noarch 1.8.4-5.fc18 will be erased
---> Package ant-apache-oro.noarch 1.8.4-5.fc18 will be erased
---> Package ant-apache-regexp.noarch 1.8.4-5.fc18 will be erased
---> Package ant-apache-resolver.noarch 1.8.4-5.fc18 will be erased
---> Package ant-apache-xalan2.noarch 1.8.4-5.fc18 will be erased
---> Package ant-commons-logging.noarch 1.8.4-5.fc18 will be erased
---> Package ant-commons-net.noarch 1.8.4-5.fc18 will be erased
---> Package ant-javamail.noarch 1.8.4-5.fc18 will be erased
---> Package ant-jdepend.noarch 1.8.4-5.fc18 will be erased
---> Package ant-jmf.noarch 1.8.4-5.fc18 will be erased
---> Package ant-jsch.noarch 1.8.4-5.fc18 will be erased
---> Package ant-junit.noarch 1.8.4-5.fc18 will be erased
---> Package ant-scripts.noarch 1.8.4-5.fc18 will be erased
---> Package ant-swing.noarch 1.8.4-5.fc18 will be erased
---> Package ant-testutil.noarch 1.8.4-5.fc18 will be erased
---> Package apache-commons-el.noarch 1.0-24.fc18 will be erased
---> Package apache-commons-net.noarch 3.2-1.fc18 will be erased
---> Package aspell-devel.x86_64 12:0.60.6.1-5.fc18 will be erased
---> Package at-spi2-atk-devel.x86_64 2.6.2-1.fc18 will be erased
---> Package atinject.noarch 1-8.20100611svn86.fc18 will be erased
---> Package atk-devel.x86_64 2.6.0-1.fc18 will be erased
---> Package attica-devel.x86_64 0.4.0-2.fc18 will be erased
---> Package aubio-devel.x86_64 0.3.2-12.fc18 will be erased
---> Package audiofile-devel.x86_64 1:0.2.7-4.fc18 will be erased
---> Package audit-libs-devel.x86_64 2.2.2-3.fc18 will be erased
---> Package batik.noarch 1.8-0.5.svn1230816.fc18 will be erased
---> Package bluez-libs-devel.x86_64 4.101-6.fc18 will be erased
---> Package bzip2-devel.x86_64 1.0.6-7.fc18 will be erased
---> Package c-ares-devel.x86_64 1.9.1-2.fc18 will be erased
---> Package cal10n.noarch 0.7.4-9.fc18 will be erased
---> Package check-devel.x86_64 0.9.9-1.fc18 will be erased
---> Package chmlib-devel.x86_64 0.40-6.fc18 will be erased
---> Package classpathx-mail.noarch 1.1.2-5.fc18 will be erased
---> Package cwiid-devel.x86_64 0.6.00-19.20100505gitfadf11e.fc18 will be erased
---> Package cyrus-sasl-devel.x86_64 2.1.23-37.fc18 will be erased
---> Package dbus-devel.x86_64 1:1.6.8-2.fc18 will be erased
---> Package dbus-glib-devel.x86_64 0.100-1.fc18 will be erased
---> Package dynamite.x86_64 0.1.1-7.fc18 will be erased
---> Package dynamite-devel.x86_64 0.1.1-7.fc18 will be erased
---> Package eclipse-ecf-core.noarch 3.5.6-3.fc18 will be erased
---> Package eclipse-emf-core.noarch 1:2.8.1-7.fc18 will be erased
---> Package eclipse-equinox-osgi.x86_64 1:4.2.2-0.10.git20121217.fc18 will be erased
---> Package eclipse-jdt.x86_64 1:4.2.2-0.10.git20121217.fc18 will be erased
---> Package eclipse-pde.x86_64 1:4.2.2-0.10.git20121217.fc18 will be erased
---> Package eclipse-platform.x86_64 1:4.2.2-0.10.git20121217.fc18 will be erased
---> Package eclipse-swt.x86_64 1:4.2.2-0.10.git20121217.fc18 will be erased
---> Package elektra-devel.x86_64 0.7.0-8.fc18 will be erased
---> Package enchant-devel.x86_64 1:1.6.0-5.fc18 will be erased
---> Package expat-devel.x86_64 2.1.0-4.fc18 will be erased
---> Package felix-bundlerepository.noarch 1.6.6-7.fc18 will be erased
---> Package felix-framework.noarch 4.0.2-4.fc18 will be erased
---> Package felix-gogo-command.noarch 0.12.0-4.fc18 will be erased
---> Package felix-gogo-runtime.noarch 0.10.0-5.fc18 will be erased
---> Package felix-gogo-shell.noarch 0.10.0-4.fc18 will be erased
---> Package felix-osgi-compendium.noarch 1.4.0-12.fc18 will be erased
---> Package felix-osgi-core.noarch 1.4.0-10.fc18 will be erased
---> Package felix-osgi-foundation.noarch 1.2.0-9.fc18 will be erased
---> Package felix-shell.noarch 1.4.2-7.fc18 will be erased
---> Package felix-utils.noarch 1.1.0-5.fc18 will be erased
---> Package fftw.x86_64 3.3.3-5.fc18 will be erased
---> Package fftw-devel.x86_64 3.3.3-5.fc18 will be erased
---> Package fftw-libs.x86_64 3.3.3-5.fc18 will be erased
---> Package fftw-libs-long.x86_64 3.3.3-5.fc18 will be erased
---> Package fftw-libs-quad.x86_64 3.3.3-5.fc18 will be erased
---> Package flac-devel.x86_64 1.2.1-10.fc18 will be erased
---> Package flex-devel.x86_64 2.5.36-1.fc18 will be erased
---> Package fontpackages-devel.noarch 1.44-5.fc18 will be erased
---> Package fribidi-devel.x86_64 0.19.4-1.fc18 will be erased
---> Package gc-devel.x86_64 7.2c-3.fc18 will be erased
---> Package geronimo-annotation.noarch 1.0-8.fc18 will be erased
---> Package gettext-common-devel.noarch 0.18.1.1-17.fc18 will be erased
---> Package giflib-devel.x86_64 4.1.6-6.fc18 will be erased
---> Package glassfish-jsp.noarch 2.2.5-2.fc18 will be erased
---> Package glassfish-jsp-api.noarch 2.2.1-4.fc18 will be erased
---> Package glib-devel.x86_64 1:1.2.10-37.fc18 will be erased
---> Package glib2-devel.x86_64 2.34.2-2.fc18 will be erased
---> Package glibc-devel.x86_64 2.16-28.fc18 will be erased
---> Package gmime-devel.x86_64 2.6.12-1.fc18 will be erased
---> Package gnome-sharp.x86_64 2.24.1-10.fc18 will be erased
---> Package gnome-sharp-devel.x86_64 2.24.1-10.fc18 will be erased
---> Package google-chrome-stable.x86_64 25.0.1364.97-183676 will be erased
---> Package gtk-sharp2-devel.x86_64 2.12.11-6.fc18 will be erased
---> Package hunspell-devel.x86_64 1.3.2-8.fc18 will be erased
---> Package icu4j-eclipse.noarch 1:4.4.2.2-12.fc18 will be erased
---> Package jack-audio-connection-kit-devel.x86_64 1.9.9.5-1.fc18 will be erased
---> Package jai-imageio-core.noarch 1.2-0.11.20100217cvs.fc18 will be erased
---> Package jakarta-commons-httpclient.noarch 1:3.1-12.fc18 will be erased
---> Package java-1.7.0-openjdk-devel.x86_64 1:1.7.0.9-2.3.7.0.fc18 will be erased
---> Package java-1.7.0-openjdk-javadoc.noarch 1:1.7.0.9-2.3.7.0.fc18 will be erased
---> Package jdepend.noarch 2.9.1-7.fc18 will be erased
---> Package jetty-continuation.noarch 8.1.5-6.fc18 will be erased
---> Package jetty-http.noarch 8.1.5-6.fc18 will be erased
---> Package jetty-io.noarch 8.1.5-6.fc18 will be erased
---> Package jetty-jmx.noarch 8.1.5-6.fc18 will be erased
---> Package jetty-parent.noarch 19-4.fc18 will be erased
---> Package jetty-project.noarch 8.1.5-6.fc18 will be erased
---> Package jetty-security.noarch 8.1.5-6.fc18 will be erased
---> Package jetty-server.noarch 8.1.5-6.fc18 will be erased
---> Package jetty-servlet.noarch 8.1.5-6.fc18 will be erased
---> Package jetty-util.noarch 8.1.5-6.fc18 will be erased
---> Package jsch.noarch 0.1.48-2.fc18 will be erased
---> Package jvnet-parent.noarch 3-6.fc18 will be erased
---> Package jzlib.noarch 1.1.0-3.fc18 will be erased
---> Package kernel-devel.x86_64 3.7.2-201.fc18 will be erased
---> Package kernel-devel.x86_64 3.7.2-204.fc18 will be erased
---> Package kernel-devel.x86_64 3.7.4-204.fc18 will be erased
---> Package kernel-devel.x86_64 3.7.5-201.fc18 will be erased
---> Package kernel-devel.x86_64 3.7.6-201.fc18 will be erased
---> Package kernel-devel.x86_64 3.7.7-201.fc18 will be erased
---> Package kernel-devel.x86_64 3.7.8-202.fc18 will be erased
---> Package kernel-devel.x86_64 3.7.9-201.fc18 will be erased
---> Package kernel-devel.x86_64 3.7.9-205.fc18 will be erased
---> Package keyutils-libs-devel.x86_64 1.5.5-3.fc18 will be erased
---> Package kxml.noarch 2.2.2-12.fc18 will be erased
---> Package ladspa-devel.x86_64 1.13-9.fc18 will be erased
---> Package lcms-devel.x86_64 1.19-7.fc18 will be erased
---> Package lcms2-devel.x86_64 2.4-1.fc18 will be erased
---> Package lilv-devel.x86_64 0.14.4-1.fc18 will be erased
---> Package link-grammar-devel.x86_64 4.7.9-1.fc18 will be erased
---> Package luabind-devel.i686 0.9.1-5.fc18 will be erased
---> Package lv2-devel.x86_64 1.2.0-1.fc18 will be erased
---> Package mesa-libOSMesa-devel.x86_64 9.0.1-4.fc18 will be erased
---> Package mono-devel.x86_64 2.10.8-3.fc18 will be erased
---> Package ncurses-devel.x86_64 5.9-7.20121017.fc18 will be erased
---> Package nspr-devel.x86_64 4.9.5-2.fc18 will be erased
---> Package nss-devel.x86_64 3.14.3-1.fc18 will be erased
---> Package nss-softokn-devel.x86_64 3.14.3-1.fc18 will be erased
---> Package nss-softokn-freebl-devel.x86_64 3.14.3-1.fc18 will be erased
---> Package nss-util-devel.x86_64 3.14.3-1.fc18 will be erased
---> Package objectweb-asm.noarch 3.3.1-4.fc18 will be erased
---> Package ode-devel.x86_64 0.12-1.fc18 will be erased
---> Package openldap-devel.x86_64 2.4.33-3.fc18 will be erased
---> Package p11-kit-devel.x86_64 0.14-1.fc18 will be erased
---> Package pam-devel.x86_64 1.1.6-3.fc18.1 will be erased
---> Package perl-CPAN.noarch 1.9800-239.fc18 will be erased
---> Package perl-Data-Dumper.x86_64 2.135.06-239.fc18 will be erased
---> Package perl-Digest-SHA.x86_64 1:5.74-3.fc18 will be erased
---> Package perl-ExtUtils-Install.noarch 1.58-239.fc18 will be erased
---> Package perl-ExtUtils-MakeMaker.noarch 6.63.2-239.fc18 will be erased
---> Package perl-ExtUtils-ParseXS.noarch 1:3.16-239.fc18 will be erased
---> Package perl-HTTP-Tiny.noarch 0.017-239.fc18 will be erased
---> Package perl-Test-Harness.noarch 3.23-239.fc18 will be erased
---> Package perl-Test-Simple.noarch 0.98-239.fc18 will be erased
---> Package perl-XML-LibXML.x86_64 1:2.0004-1.fc18 will be erased
---> Package perl-devel.x86_64 4:5.16.2-239.fc18 will be erased
---> Package physfs-devel.x86_64 2.0.2-3.fc18 will be erased
---> Package policycoreutils-devel.x86_64 2.1.13-55.fc18 will be erased
---> Package popt-devel.x86_64 1.13-12.fc18 will be erased
---> Package postgresql-devel.x86_64 9.2.3-1.fc18 will be erased
---> Package pth-devel.x86_64 2.0.7-17.fc18 will be erased
---> Package pygobject2-devel.x86_64 2.28.6-7.fc18 will be erased
---> Package python-devel.x86_64 2.7.3-13.fc18 will be erased
---> Package python3-devel.x86_64 3.3.0-1.fc18 will be erased
---> Package raptor2-devel.x86_64 2.0.7-2.fc18 will be erased
---> Package readline-devel.x86_64 6.2-5.fc18 will be erased
---> Package redhat-lsb.x86_64 4.1-10.fc18 will be erased
---> Package redhat-lsb-core.x86_64 4.1-10.fc18 will be erased
---> Package redhat-lsb-cxx.x86_64 4.1-10.fc18 will be erased
---> Package redhat-lsb-desktop.x86_64 4.1-10.fc18 will be erased
---> Package redhat-lsb-languages.x86_64 4.1-10.fc18 will be erased
---> Package redhat-lsb-printing.x86_64 4.1-10.fc18 will be erased
---> Package redhat-lsb-submod-multimedia.x86_64 4.1-10.fc18 will be erased
---> Package redhat-lsb-submod-security.x86_64 4.1-10.fc18 will be erased
---> Package rpm-devel.x86_64 4.10.3.1-1.fc18 will be erased
---> Package sac.noarch 1.3-13.fc18 will be erased
---> Package sat4j.noarch 2.3.0-4.fc18 will be erased
---> Package selinux-policy-devel.noarch 3.11.1-81.fc18 will be erased
---> Package selinux-policy-doc.noarch 3.11.1-81.fc18 will be erased
---> Package serd-devel.x86_64 0.18.0-1.fc18 will be erased
---> Package shared-desktop-ontologies-devel.noarch 0.10.0-3.fc18 will be erased
---> Package slf4j.noarch 1.7.2-4.fc18 will be erased
---> Package sord-devel.x86_64 0.10.4-2.fc18 will be erased
---> Package soundtouch-devel.x86_64 1.4.0-6.fc18 will be erased
---> Package sqlite-devel.x86_64 3.7.13-2.fc18 will be erased
---> Package squirrel-devel.x86_64 2.2.5-2.fc18 will be erased
---> Package sratom-devel.x86_64 0.2.0-4.fc18 will be erased
---> Package stax2-api.noarch 3.1.1-4.fc18 will be erased
---> Package suil-devel.x86_64 0.6.10-1.fc18 will be erased
---> Package systemtap-sdt-devel.x86_64 2.1-1.fc18 will be erased
---> Package t1lib-devel.x86_64 5.1.2-10.fc18 will be erased
---> Package taglib-devel.x86_64 1.8-3.20121215git.fc18 will be erased
---> Package tcl-devel.x86_64 1:8.5.13-1.fc18 will be erased
---> Package tcp_wrappers-devel.x86_64 7.6-70.fc18 will be erased
---> Package tinyxml-devel.x86_64 2.6.1-4.fc18 will be erased
---> Package tomcat-el-2.2-api.noarch 7.0.37-1.fc18 will be erased
---> Package tslib-devel.x86_64 1.0-5.fc18 will be erased
---> Package vala-devel.x86_64 0.18.1-1.fc18 will be erased
---> Package vamp-plugin-sdk-devel.x86_64 2.4-1.fc18 will be erased
---> Package woodstox-core.noarch 4.1.2-3.fc18 will be erased
---> Package xalan-c-devel.x86_64 1.10.0-12.fc18 will be erased
---> Package xerces-c-devel.x86_64 3.1.1-3.fc18 will be erased
---> Package xorg-x11-proto-devel.noarch 7.6-24.fc18 will be erased
---> Package xz-devel.x86_64 5.1.2-2alpha.fc18 will be erased
---> Package yajl-devel.x86_64 2.0.4-1.fc18 will be erased
--> Finished dependency resolution

Dependencies Resolved

================================================================================
 Package                    Arch   Version                        Repository
                                                                           Size
================================================================================
Removing:
 DevIL-devel                x86_64 1.7.8-10.fc18                  @System   0  
 GeoIP-devel                x86_64 1.4.8-4.fc18                   @System   0  
 Hermes-devel               x86_64 1.3.3-20.fc18                  @System   0  
 LibRaw-devel               x86_64 0.14.6-3.fc18                  @System   0  
 aiksaurus-devel            x86_64 1:1.2.1-26.fc18                @System   0  
 alsa-lib-devel             x86_64 1.0.26-2.fc18                  @System   0  
 ant                        noarch 1.8.4-5.fc18                   @System   0  
 ant-antlr                  noarch 1.8.4-5.fc18                   @System   0  
 ant-apache-bcel            noarch 1.8.4-5.fc18                   @System   0  
 ant-apache-bsf             noarch 1.8.4-5.fc18                   @System   0  
 ant-apache-log4j           noarch 1.8.4-5.fc18                   @System   0  
 ant-apache-oro             noarch 1.8.4-5.fc18                   @System   0  
 ant-apache-regexp          noarch 1.8.4-5.fc18                   @System   0  
 ant-apache-resolver        noarch 1.8.4-5.fc18                   @System   0  
 ant-apache-xalan2          noarch 1.8.4-5.fc18                   @System   0  
 ant-commons-logging        noarch 1.8.4-5.fc18                   @System   0  
 ant-commons-net            noarch 1.8.4-5.fc18                   @System   0  
 ant-javamail               noarch 1.8.4-5.fc18                   @System   0  
 ant-jdepend                noarch 1.8.4-5.fc18                   @System   0  
 ant-jmf                    noarch 1.8.4-5.fc18                   @System   0  
 ant-jsch                   noarch 1.8.4-5.fc18                   @System   0  
 ant-junit                  noarch 1.8.4-5.fc18                   @System   0  
 ant-scripts                noarch 1.8.4-5.fc18                   @System   0  
 ant-swing                  noarch 1.8.4-5.fc18                   @System   0  
 ant-testutil               noarch 1.8.4-5.fc18                   @System   0  
 apache-commons-el          noarch 1.0-24.fc18                    @System   0  
 apache-commons-net         noarch 3.2-1.fc18                     @System   0  
 aspell-devel               x86_64 12:0.60.6.1-5.fc18             @System   0  
 at-spi2-atk-devel          x86_64 2.6.2-1.fc18                   @System   0  
 atinject                   noarch 1-8.20100611svn86.fc18         @System   0  
 atk-devel                  x86_64 2.6.0-1.fc18                   @System   0  
 attica-devel               x86_64 0.4.0-2.fc18                   @System   0  
 aubio-devel                x86_64 0.3.2-12.fc18                  @System   0  
 audiofile-devel            x86_64 1:0.2.7-4.fc18                 @System   0  
 audit-libs-devel           x86_64 2.2.2-3.fc18                   @System   0  
 batik                      noarch 1.8-0.5.svn1230816.fc18        @System   0  
 bluez-libs-devel           x86_64 4.101-6.fc18                   @System   0  
 bzip2-devel                x86_64 1.0.6-7.fc18                   @System   0  
 c-ares-devel               x86_64 1.9.1-2.fc18                   @System   0  
 cal10n                     noarch 0.7.4-9.fc18                   @System   0  
 check-devel                x86_64 0.9.9-1.fc18                   @System   0  
 chmlib-devel               x86_64 0.40-6.fc18                    @System   0  
 classpathx-mail            noarch 1.1.2-5.fc18                   @System   0  
 cwiid-devel                x86_64 0.6.00-19.20100505gitfadf11e.fc18
                                                                  @System   0  
 cyrus-sasl-devel           x86_64 2.1.23-37.fc18                 @System   0  
 dbus-devel                 x86_64 1:1.6.8-2.fc18                 @System   0  
 dbus-glib-devel            x86_64 0.100-1.fc18                   @System   0  
 dynamite                   x86_64 0.1.1-7.fc18                   @System   0  
 dynamite-devel             x86_64 0.1.1-7.fc18                   @System   0  
 eclipse-ecf-core           noarch 3.5.6-3.fc18                   @System   0  
 eclipse-emf-core           noarch 1:2.8.1-7.fc18                 @System   0  
 eclipse-equinox-osgi       x86_64 1:4.2.2-0.10.git20121217.fc18  @System   0  
 eclipse-jdt                x86_64 1:4.2.2-0.10.git20121217.fc18  @System   0  
 eclipse-pde                x86_64 1:4.2.2-0.10.git20121217.fc18  @System   0  
 eclipse-platform           x86_64 1:4.2.2-0.10.git20121217.fc18  @System   0  
 eclipse-swt                x86_64 1:4.2.2-0.10.git20121217.fc18  @System   0  
 elektra-devel              x86_64 0.7.0-8.fc18                   @System   0  
 enchant-devel              x86_64 1:1.6.0-5.fc18                 @System   0  
 expat-devel                x86_64 2.1.0-4.fc18                   @System   0  
 felix-bundlerepository     noarch 1.6.6-7.fc18                   @System   0  
 felix-framework            noarch 4.0.2-4.fc18                   @System   0  
 felix-gogo-command         noarch 0.12.0-4.fc18                  @System   0  
 felix-gogo-runtime         noarch 0.10.0-5.fc18                  @System   0  
 felix-gogo-shell           noarch 0.10.0-4.fc18                  @System   0  
 felix-osgi-compendium      noarch 1.4.0-12.fc18                  @System   0  
 felix-osgi-core            noarch 1.4.0-10.fc18                  @System   0  
 felix-osgi-foundation      noarch 1.2.0-9.fc18                   @System   0  
 felix-shell                noarch 1.4.2-7.fc18                   @System   0  
 felix-utils                noarch 1.1.0-5.fc18                   @System   0  
 fftw                       x86_64 3.3.3-5.fc18                   @System   0  
 fftw-devel                 x86_64 3.3.3-5.fc18                   @System   0  
 fftw-libs                  x86_64 3.3.3-5.fc18                   @System   0  
 fftw-libs-long             x86_64 3.3.3-5.fc18                   @System   0  
 fftw-libs-quad             x86_64 3.3.3-5.fc18                   @System   0  
 flac-devel                 x86_64 1.2.1-10.fc18                  @System   0  
 flex-devel                 x86_64 2.5.36-1.fc18                  @System   0  
 fontpackages-devel         noarch 1.44-5.fc18                    @System   0  
 fribidi-devel              x86_64 0.19.4-1.fc18                  @System   0  
 gc-devel                   x86_64 7.2c-3.fc18                    @System   0  
 geronimo-annotation        noarch 1.0-8.fc18                     @System   0  
 gettext-common-devel       noarch 0.18.1.1-17.fc18               @System   0  
 giflib-devel               x86_64 4.1.6-6.fc18                   @System   0  
 glassfish-jsp              noarch 2.2.5-2.fc18                   @System   0  
 glassfish-jsp-api          noarch 2.2.1-4.fc18                   @System   0  
 glib-devel                 x86_64 1:1.2.10-37.fc18               @System   0  
 glib2-devel                x86_64 2.34.2-2.fc18                  @System   0  
 glibc-devel                x86_64 2.16-28.fc18                   @System   0  
 gmime-devel                x86_64 2.6.12-1.fc18                  @System   0  
 gnome-sharp                x86_64 2.24.1-10.fc18                 @System   0  
 gnome-sharp-devel          x86_64 2.24.1-10.fc18                 @System   0  
 google-chrome-stable       x86_64 25.0.1364.97-183676            @System   0  
 gtk-sharp2-devel           x86_64 2.12.11-6.fc18                 @System   0  
 hunspell-devel             x86_64 1.3.2-8.fc18                   @System   0  
 icu4j-eclipse              noarch 1:4.4.2.2-12.fc18              @System   0  
 jack-audio-connection-kit-devel
                            x86_64 1.9.9.5-1.fc18                 @System   0  
 jai-imageio-core           noarch 1.2-0.11.20100217cvs.fc18      @System   0  
 jakarta-commons-httpclient noarch 1:3.1-12.fc18                  @System   0  
 java-1.7.0-openjdk-devel   x86_64 1:1.7.0.9-2.3.7.0.fc18         @System   0  
 java-1.7.0-openjdk-javadoc noarch 1:1.7.0.9-2.3.7.0.fc18         @System   0  
 jdepend                    noarch 2.9.1-7.fc18                   @System   0  
 jetty-continuation         noarch 8.1.5-6.fc18                   @System   0  
 jetty-http                 noarch 8.1.5-6.fc18                   @System   0  
 jetty-io                   noarch 8.1.5-6.fc18                   @System   0  
 jetty-jmx                  noarch 8.1.5-6.fc18                   @System   0  
 jetty-parent               noarch 19-4.fc18                      @System   0  
 jetty-project              noarch 8.1.5-6.fc18                   @System   0  
 jetty-security             noarch 8.1.5-6.fc18                   @System   0  
 jetty-server               noarch 8.1.5-6.fc18                   @System   0  
 jetty-servlet              noarch 8.1.5-6.fc18                   @System   0  
 jetty-util                 noarch 8.1.5-6.fc18                   @System   0  
 jsch                       noarch 0.1.48-2.fc18                  @System   0  
 jvnet-parent               noarch 3-6.fc18                       @System   0  
 jzlib                      noarch 1.1.0-3.fc18                   @System   0  
 kernel-devel               x86_64 3.7.2-201.fc18                 @System   0  
 kernel-devel               x86_64 3.7.2-204.fc18                 @System   0  
 kernel-devel               x86_64 3.7.4-204.fc18                 @System   0  
 kernel-devel               x86_64 3.7.5-201.fc18                 @System   0  
 kernel-devel               x86_64 3.7.6-201.fc18                 @System   0  
 kernel-devel               x86_64 3.7.7-201.fc18                 @System   0  
 kernel-devel               x86_64 3.7.8-202.fc18                 @System   0  
 kernel-devel               x86_64 3.7.9-201.fc18                 @System   0  
 kernel-devel               x86_64 3.7.9-205.fc18                 @System   0  
 keyutils-libs-devel        x86_64 1.5.5-3.fc18                   @System   0  
 kxml                       noarch 2.2.2-12.fc18                  @System   0  
 ladspa-devel               x86_64 1.13-9.fc18                    @System   0  
 lcms-devel                 x86_64 1.19-7.fc18                    @System   0  
 lcms2-devel                x86_64 2.4-1.fc18                     @System   0  
 lilv-devel                 x86_64 0.14.4-1.fc18                  @System   0  
 link-grammar-devel         x86_64 4.7.9-1.fc18                   @System   0  
 luabind-devel              i686   0.9.1-5.fc18                   @System   0  
 lv2-devel                  x86_64 1.2.0-1.fc18                   @System   0  
 mesa-libOSMesa-devel       x86_64 9.0.1-4.fc18                   @System   0  
 mono-devel                 x86_64 2.10.8-3.fc18                  @System   0  
 ncurses-devel              x86_64 5.9-7.20121017.fc18            @System   0  
 nspr-devel                 x86_64 4.9.5-2.fc18                   @System   0  
 nss-devel                  x86_64 3.14.3-1.fc18                  @System   0  
 nss-softokn-devel          x86_64 3.14.3-1.fc18                  @System   0  
 nss-softokn-freebl-devel   x86_64 3.14.3-1.fc18                  @System   0  
 nss-util-devel             x86_64 3.14.3-1.fc18                  @System   0  
 objectweb-asm              noarch 3.3.1-4.fc18                   @System   0  
 ode-devel                  x86_64 0.12-1.fc18                    @System   0  
 openldap-devel             x86_64 2.4.33-3.fc18                  @System   0  
 p11-kit-devel              x86_64 0.14-1.fc18                    @System   0  
 pam-devel                  x86_64 1.1.6-3.fc18.1                 @System   0  
 perl-CPAN                  noarch 1.9800-239.fc18                @System   0  
 perl-Data-Dumper           x86_64 2.135.06-239.fc18              @System   0  
 perl-Digest-SHA            x86_64 1:5.74-3.fc18                  @System   0  
 perl-ExtUtils-Install      noarch 1.58-239.fc18                  @System   0  
 perl-ExtUtils-MakeMaker    noarch 6.63.2-239.fc18                @System   0  
 perl-ExtUtils-ParseXS      noarch 1:3.16-239.fc18                @System   0  
 perl-HTTP-Tiny             noarch 0.017-239.fc18                 @System   0  
 perl-Test-Harness          noarch 3.23-239.fc18                  @System   0  
 perl-Test-Simple           noarch 0.98-239.fc18                  @System   0  
 perl-XML-LibXML            x86_64 1:2.0004-1.fc18                @System   0  
 perl-devel                 x86_64 4:5.16.2-239.fc18              @System   0  
 physfs-devel               x86_64 2.0.2-3.fc18                   @System   0  
 policycoreutils-devel      x86_64 2.1.13-55.fc18                 @System   0  
 popt-devel                 x86_64 1.13-12.fc18                   @System   0  
 postgresql-devel           x86_64 9.2.3-1.fc18                   @System   0  
 pth-devel                  x86_64 2.0.7-17.fc18                  @System   0  
 pygobject2-devel           x86_64 2.28.6-7.fc18                  @System   0  
 python-devel               x86_64 2.7.3-13.fc18                  @System   0  
 python3-devel              x86_64 3.3.0-1.fc18                   @System   0  
 raptor2-devel              x86_64 2.0.7-2.fc18                   @System   0  
 readline-devel             x86_64 6.2-5.fc18                     @System   0  
 redhat-lsb                 x86_64 4.1-10.fc18                    @System   0  
 redhat-lsb-core            x86_64 4.1-10.fc18                    @System   0  
 redhat-lsb-cxx             x86_64 4.1-10.fc18                    @System   0  
 redhat-lsb-desktop         x86_64 4.1-10.fc18                    @System   0  
 redhat-lsb-languages       x86_64 4.1-10.fc18                    @System   0  
 redhat-lsb-printing        x86_64 4.1-10.fc18                    @System   0  
 redhat-lsb-submod-multimedia
                            x86_64 4.1-10.fc18                    @System   0  
 redhat-lsb-submod-security x86_64 4.1-10.fc18                    @System   0  
 rpm-devel                  x86_64 4.10.3.1-1.fc18                @System   0  
 sac                        noarch 1.3-13.fc18                    @System   0  
 sat4j                      noarch 2.3.0-4.fc18                   @System   0  
 selinux-policy-devel       noarch 3.11.1-81.fc18                 @System   0  
 selinux-policy-doc         noarch 3.11.1-81.fc18                 @System   0  
 serd-devel                 x86_64 0.18.0-1.fc18                  @System   0  
 shared-desktop-ontologies-devel
                            noarch 0.10.0-3.fc18                  @System   0  
 slf4j                      noarch 1.7.2-4.fc18                   @System   0  
 sord-devel                 x86_64 0.10.4-2.fc18                  @System   0  
 soundtouch-devel           x86_64 1.4.0-6.fc18                   @System   0  
 sqlite-devel               x86_64 3.7.13-2.fc18                  @System   0  
 squirrel-devel             x86_64 2.2.5-2.fc18                   @System   0  
 sratom-devel               x86_64 0.2.0-4.fc18                   @System   0  
 stax2-api                  noarch 3.1.1-4.fc18                   @System   0  
 suil-devel                 x86_64 0.6.10-1.fc18                  @System   0  
 systemtap-sdt-devel        x86_64 2.1-1.fc18                     @System   0  
 t1lib-devel                x86_64 5.1.2-10.fc18                  @System   0  
 taglib-devel               x86_64 1.8-3.20121215git.fc18         @System   0  
 tcl-devel                  x86_64 1:8.5.13-1.fc18                @System   0  
 tcp_wrappers-devel         x86_64 7.6-70.fc18                    @System   0  
 tinyxml-devel              x86_64 2.6.1-4.fc18                   @System   0  
 tomcat-el-2.2-api          noarch 7.0.37-1.fc18                  @System   0  
 tslib-devel                x86_64 1.0-5.fc18                     @System   0  
 vala-devel                 x86_64 0.18.1-1.fc18                  @System   0  
 vamp-plugin-sdk-devel      x86_64 2.4-1.fc18                     @System   0  
 woodstox-core              noarch 4.1.2-3.fc18                   @System   0  
 xalan-c-devel              x86_64 1.10.0-12.fc18                 @System   0  
 xerces-c-devel             x86_64 3.1.1-3.fc18                   @System   0  
 xorg-x11-proto-devel       noarch 7.6-24.fc18                    @System   0  
 xz-devel                   x86_64 5.1.2-2alpha.fc18              @System   0  
 yajl-devel                 x86_64 2.0.4-1.fc18                   @System   0  
Downgrading:
 perl-ExtUtils-Manifest     noarch 1.60-3.fc18                    fedora   30 k
 setroubleshoot             x86_64 3.1.18-1.fc18                  fedora  120 k
 setroubleshoot-server      x86_64 3.1.18-1.fc18                  fedora  340 k

Transaction Summary
================================================================================
Remove     204 Packages
Downgrade    3 Packages

Total size: 490 k
Is this ok [y/N]: 
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Check
Running Transaction Test


Transaction Check Error:
  package setroubleshoot-server-3.1.19-3.fc18.x86_64 (which is newer than setroubleshoot-server-3.1.18-1.fc18.x86_64) is already installed
  package setroubleshoot-3.1.19-3.fc18.x86_64 (which is newer than setroubleshoot-3.1.18-1.fc18.x86_64) is already installed
  package perl-ExtUtils-Manifest-0:1.61-239.fc18.noarch (which is newer than perl-ExtUtils-Manifest-1.60-3.fc18.noarch) is already installed

Error Summary
-------------
Comment 1 Ales Kozumplik 2013-03-01 04:54:37 EST
run 'dnf --version' and paste the output.
Comment 2 Ales Kozumplik 2013-03-01 07:00:55 EST
Related commit: e74ca3607e5a592237c10c08ed469ec51c73a894.
Comment 3 Rahul Sundaram 2013-03-01 10:44:55 EST
dnf --version
0.2.21
  Installed: dnf-0:0.2.21-1.git050524e.fc18.noarch at 2013-02-14 18:16
  Built    : Fedora Project at 2013-02-11 12:00

  Installed: rpm-0:4.10.3.1-1.fc18.x86_64 at 2013-02-09 03:26
  Built    : Fedora Project at 2013-02-06 09:54
Comment 4 Ales Kozumplik 2013-03-21 13:06:17 EDT
Fixed by ac1c942.
Comment 5 Fedora End Of Life 2013-04-03 16:22:03 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 19 development cycle.
Changing version to '19'.

(As we did not run this process for some time, it could affect also pre-Fedora 19 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 19 End Of Life. Thank you.)

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora19

Note You need to log in before you can comment on or make changes to this bug.