Bug 916882 - Warning: Skipping the data of table mysql.event. Specify the --events option explicitly.
Summary: Warning: Skipping the data of table mysql.event. Specify the --events option ...
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: mysql   
(Show other bugs)
Version: 18
Hardware: All Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Tom Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-01 08:01 UTC by Vilius Šumskas
Modified: 2013-03-02 11:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-02 11:20:25 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Vilius Šumskas 2013-03-01 08:01:09 UTC
Description of problem:
Since upgrade from 5.5.29 to 5.5.30 package version all our mysqldump scripts emits a warning "Warning: Skipping the data of table mysql.event. Specify the --events option explicitly." We tried using --ignore-table=mysql.event as per documentation but it still gives the same warning.


Version-Release number of selected component (if applicable):
mysql-5.5.30-1.fc18.i686

How reproducible:
Always

Steps to Reproduce:
1. Run "mysqldump --all-databases > temp.sql" or "mysqldump --all-databases --ignore-table=mysql.event > temp.sql"
  
Actual results:
Warning: Skipping the data of table mysql.event. Specify the --events option explicitly.

Expected results:
The mysqldump command should not emit warnings if I use ignore-table options.

Additional info:
The bug appeared after changes in upstream http://bugs.mysql.com/bug.php?id=55587

Comment 1 Honza Horak 2013-03-01 10:32:48 UTC
Well, I'm testing that on mysql-5.5.30-1.fc18.x86_64 and the warning is printed in case --ignore-table is not used, but I don't see any warning when --ignore-table=mysql.event is used. So basically it works as expected for me.
Could you share your options in my.cnf?

Comment 2 Vilius Šumskas 2013-03-02 11:20:25 UTC
All our mysqldump scripts are run by cron. Seems that I had to restart crond after correcting the scripts for some reason. Now it works.

Closing.


Note You need to log in before you can comment on or make changes to this bug.