Bug 9169 - backspace gives ^? in rxvt-based terminal
backspace gives ^? in rxvt-based terminal
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: vim (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-06 17:32 EST by Jeremy Katz
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-11 05:24:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2000-02-06 17:32:15 EST
Okay, easiest way to reproduce

1) Start rxvt
2) run vim
3) Insert some text and then try to use backspace to delete it

At first, I thought it might be an ncurses bug, but joe doesn't exhibit the
same behavior, yet is also linked to ncurses.

This bug was not present in 6.0, appeared in 6.1, and is still present in
RawHide.
Comment 1 Bernhard Rosenkraenzer 2000-02-10 07:31:59 EST
It was a problem with the xterm termcap description in ncurses.
Get the current packages for ncurses, termcap, rxvt, XFree86* and it'll work.
Comment 2 Jeremy Katz 2000-02-11 00:38:59 EST
I just tried it on my box running piglet, same result.  The packages of termcap,
ncurses, rxvt, XFree, and vim are all newer in piglet than rawhide, yet I still
don't have working backspace in vi in an rxvt.
Comment 3 Bernhard Rosenkraenzer 2000-02-11 05:24:59 EST
I know. The bug resolution "rawhide" usually refers to our internal tree, from
which rawhide is built every couple of days. It's fixed there - so
it'll be fixed in rawhide as soon as a new rawhide is built.

Note You need to log in before you can comment on or make changes to this bug.