Bug 917002 - munin-asyncd should wait for munin-node
Summary: munin-asyncd should wait for munin-node
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: munin
Version: 18
Hardware: Unspecified
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-01 12:09 UTC by cristi falcas
Modified: 2013-04-09 18:16 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-11 01:19:36 UTC
Type: Bug


Attachments (Terms of Use)

Description cristi falcas 2013-03-01 12:09:08 UTC
Description of problem:
munin-asyncd needs munin-node to properly run. Maybe systemctl knows how to do this?
munin-asyncd should be launched in background. Maybe systemctl knows how to do this?
Also, in the systemctl service file, the pid file is the same as the one from munin-node. But I don't know if this matters.

Version-Release number of selected component (if applicable):
munin-node-2.0.11.1-1.fc18.noarch
munin-async-2.0.11.1-1.fc18.noarch
munin-common-2.0.11.1-1.fc18.noarch

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Fedora Update System 2013-03-01 16:49:48 UTC
munin-2.0.11.1-2.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/munin-2.0.11.1-2.el5

Comment 2 Fedora Update System 2013-03-01 16:51:02 UTC
munin-2.0.11.1-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/munin-2.0.11.1-2.el6

Comment 3 Fedora Update System 2013-03-01 16:52:04 UTC
munin-2.0.11.1-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/munin-2.0.11.1-2.fc17

Comment 4 Fedora Update System 2013-03-01 16:52:55 UTC
munin-2.0.11.1-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/munin-2.0.11.1-2.fc18

Comment 5 cristi falcas 2013-03-01 17:39:58 UTC
I didn't see anything in this update that fixes the service files.

I was referring to this:
1. currently munin-asyncd could be started before munin-node, which will fail because it can't connect to localhost port 4949
2. doing "systemctl start munin-asyncd" is killed after a timeout because munin-asyncd doesn't go in background.
3. in /usr/lib/systemd/system/munin-asyncd.service we have:
PIDFile=/var/run/munin/munin-node.pid

Comment 6 d. johnson 2013-03-01 20:39:03 UTC
Really? that's odd.

$ git log -n 1 -p munin-asyncd.service

diff --git a/munin-asyncd.service b/munin-asyncd.service
index adfdf55..b3e8a0d 100644
--- a/munin-asyncd.service
+++ b/munin-asyncd.service
@@ -1,7 +1,8 @@
 [Unit]
 Description=Munin Async Server.
 Documentation=man:munin-node
-After=network.target
+Requires=munin-node.service
+After=network.target munin-node.service
 
 [Service]
 Type=forking


After applying the update, it should wait until node starts up.

Comment 7 cristi falcas 2013-03-01 22:09:52 UTC
Sorry about that, I read the file only between the lines it seems.

If  "Type=forking" is not working for me, can I debug it somehow? 

My result:

# systemctl status munin-asyncd | more
munin-asyncd.service - Munin Async Server.
          Loaded: loaded (/usr/lib/systemd/system/munin-asyncd.service; enabled)
          Active: failed (Result: timeout) since Fri 2013-03-01 23:50:37 EET; 18
min ago
            Docs: man:munin-node
         Process: 827 ExecStart=/usr/sbin/munin-asyncd & (code=killed, signal=TE
RM)

Mar 02 00:49:07 wikivpn.mindsoft.com systemd[1]: Starting Munin Async Server....
Mar 01 23:50:37 wikivpn.mindsoft.com systemd[1]: munin-asyncd.service operation
timed out. Terminating.
Mar 01 23:50:37 wikivpn.mindsoft.com systemd[1]: Failed to start Munin Async Ser
ver..
Mar 01 23:50:37 wikivpn.mindsoft.com systemd[1]: Unit munin-asyncd.service enter
ed failed state

Comment 8 Fedora Update System 2013-03-02 19:50:42 UTC
Package munin-2.0.11.1-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing munin-2.0.11.1-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-3199/munin-2.0.11.1-2.fc18
then log in and leave karma (feedback).

Comment 9 d. johnson 2013-03-03 03:39:32 UTC
# yum update munin\* --enablerepo=updates-testing

munin-async-2.0.11.1-2.fc18.noarch

Edit /lib/systemd/system/munin-asyncd.service,

[Service]
Type=simple
ExecStart=/usr/sbin/munin-asyncd
PrivateTmp=true

Leave [Unit] and [Install] sections as they were, but modify [Service] so it looks like the above.

# systemctl --system daemon-reload
# systemctl start munin-asyncd
# systemctl status munin-asyncd 

Does it work correctly for you?  (Seems to startup ok here, and appears to be less messy than making Type=forking happy)

Comment 10 cristi falcas 2013-03-04 08:10:20 UTC
Type=simple works for me.

Comment 11 Fedora Update System 2013-03-11 01:19:38 UTC
munin-2.0.11.1-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2013-03-11 01:21:20 UTC
munin-2.0.11.1-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2013-03-24 17:56:53 UTC
munin-2.0.11.1-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2013-03-24 18:04:00 UTC
munin-2.0.11.1-2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2013-03-25 14:22:27 UTC
munin-2.0.12-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/munin-2.0.12-2.fc18

Comment 16 Fedora Update System 2013-03-25 14:24:46 UTC
munin-2.0.12-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/munin-2.0.12-2.fc17

Comment 17 Fedora Update System 2013-03-25 14:27:49 UTC
munin-2.0.12-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/munin-2.0.12-2.el6

Comment 18 Fedora Update System 2013-03-25 14:35:13 UTC
munin-2.0.12-2.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/munin-2.0.12-2.el5

Comment 19 Fedora Update System 2013-04-05 00:03:09 UTC
munin-2.0.12-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2013-04-05 00:09:27 UTC
munin-2.0.12-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 21 Fedora Update System 2013-04-09 18:15:37 UTC
munin-2.0.12-2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2013-04-09 18:16:08 UTC
munin-2.0.12-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.