Bug 91711 - PCI bus and mga BIOS patch (from Ivan Kokshaysky)
Summary: PCI bus and mga BIOS patch (from Ivan Kokshaysky)
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-27 15:01 UTC by Michal Jaegermann
Modified: 2007-04-18 16:54 UTC (History)
0 users

Fixed In Version: 4.3.0-15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-06 17:21:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for issues in X 4.0.3 (1.41 KB, patch)
2003-05-27 15:02 UTC, Michal Jaegermann
no flags Details | Diff

Description Michal Jaegermann 2003-05-27 15:01:13 UTC
Description of problem:

This is a quote from a description by Ivan posted on axp-list:

I had couple of problems with 4.3.0:
- Detection of the primary adapter is broken. You have to
  set explicit PCI id in XF86Config to get the card detected
  as *secondary*. However, switching to VGA text console won't work then
  (most drivers don't save/restore VGA state for secondary adapters).
- Rather old bug in mga driver (since 4.1.0, IIRC) - the driver
  attempts to read the video ROM *before* enabling it. Naturally,
  this causes annoying machine check on certain platforms.

Nominally on Alpha but it looks from the code that it will really affect
all platforms.  His patch attached.

Comment 1 Michal Jaegermann 2003-05-27 15:02:51 UTC
Created attachment 91995 [details]
patch for issues in X 4.0.3

Comment 2 Mike A. Harris 2003-06-06 17:21:35 UTC
Applied to 4.3.0-15 on all-arches.


Note You need to log in before you can comment on or make changes to this bug.