Bug 917233 (CVE-2013-1802) - CVE-2013-1802 rubygem-extlib: YAML parameter parsing vulnerability
Summary: CVE-2013-1802 rubygem-extlib: YAML parameter parsing vulnerability
Status: NEW
Alias: CVE-2013-1802
Product: Security Response
Classification: Other
Component: vulnerability   
(Show other bugs)
Version: unspecified
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
Whiteboard: impact=important,public=20130114,repo...
Keywords: Security
Depends On: 917234
TreeView+ depends on / blocked
Reported: 2013-03-02 08:54 UTC by Kurt Seifried
Modified: 2018-01-30 01:02 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

Description Kurt Seifried 2013-03-02 08:54:19 UTC
Tasha Drew reports:

Researchers investigating the Rails parameter parsing vulnerability discovered 
that the same or similar vulnerable code had made its way into multiple other 
libraries. If your application uses these libraries to process untrusted data, 
it may still be vulnerable even if you have upgraded Rails. Check your Gemfile 
and Gemfile.lock for vulnerable versions of the following libraries, and if you
are using one, update it immediately.

You can update each of these by using "bundle update <gem name>". 


Vulnerable: <= 0.9.15

Fixed: 0.9.16

External references:



Comment 1 Kurt Seifried 2013-03-02 08:54:55 UTC
Created rubygem-extlib tracking bugs for this issue

Affects: epel-all [bug 917234]

Note You need to log in before you can comment on or make changes to this bug.