Bug 917260 - [GeForce 9100] [10de:0847:103c:2a7a] Garbled text screen; no X after modeset with kernel 3.9.0-0.rc0.git14.1.fc19.x86_64
[GeForce 9100] [10de:0847:103c:2a7a] Garbled text screen; no X after modeset ...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-02 07:30 EST by Steven Usdansky
Modified: 2013-09-28 07:07 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-28 07:07:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
smolt profile (3.57 KB, text/plain)
2013-03-02 07:30 EST, Steven Usdansky
no flags Details
xorg.conf (860 bytes, text/plain)
2013-03-02 07:31 EST, Steven Usdansky
no flags Details
Xorg.0.log for failed modeset (12.95 KB, text/plain)
2013-03-02 07:33 EST, Steven Usdansky
no flags Details
Xorg.0.log with nomodeset kernel parameter (23.86 KB, text/plain)
2013-03-02 07:34 EST, Steven Usdansky
no flags Details
dmesg output failed modeset (88.66 KB, text/plain)
2013-03-02 07:35 EST, Steven Usdansky
no flags Details
/var/log/messages good (3.7) and bad (3.9) kernels (746.98 KB, application/octet-stream)
2013-03-19 06:57 EDT, Steven Usdansky
no flags Details
Xorg.0.log for failed modeset with kernel-3.9.0-0.rc3.git0.3.fc19.x86_64 (11.90 KB, text/x-log)
2013-03-19 07:05 EDT, Steven Usdansky
no flags Details

  None (edit)
Description Steven Usdansky 2013-03-02 07:30:19 EST
Created attachment 704475 [details]
smolt profile

Description of problem:
Screen consists of scrambled dots instead of text after kernel modeset; X won't start

Version-Release number of selected component (if applicable):
kernel-3.9.0-0.rc0.git14.1.fc19.x86_64
xorg-x11-drv-nouveau-1.0.6-5.fc19.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Install a new kernel (3.9.0- git11 or higher)
2. Boot with that kernel
3.
  
Actual results:
Text screen consists of semi-randomly scattered dots instead of text characters. 
X will not start when command startx is executed

Expected results:
Text on screen is readable throughout the session
X starts in response to startx

Additional info:
Comment 1 Steven Usdansky 2013-03-02 07:31:43 EST
Created attachment 704476 [details]
xorg.conf

monitor does not emit a proper EDID; xorg.conf needed to get native 1680x1050 resolution
Comment 2 Steven Usdansky 2013-03-02 07:33:30 EST
Created attachment 704477 [details]
Xorg.0.log for failed modeset
Comment 3 Steven Usdansky 2013-03-02 07:34:19 EST
Created attachment 704478 [details]
Xorg.0.log with nomodeset kernel parameter
Comment 4 Steven Usdansky 2013-03-02 07:35:32 EST
Created attachment 704479 [details]
dmesg output failed modeset
Comment 5 Steven Usdansky 2013-03-02 07:44:36 EST
No problems with kernel-3.7.9-205.fc18.x86_64.
Comment 6 Adam Williamson 2013-03-08 21:40:38 EST
Best to file these bugs against the X driver component even though it's not technically correct, because it gets them to the right maintainer. New kernel builds are coming through at a rate of knots - can you try the latest ones every day or two and report back? Thanks!
Comment 7 Steven Usdansky 2013-03-09 19:50:25 EST
I've been trying new kernels as they appear. 

kernel-3.9.0-0.rc1.git0.4.fc19.x86_64 exhibits same misbehavior
Comment 8 Steven Usdansky 2013-03-16 06:27:23 EDT
kernel-3.9.0-0.rc2.git0.3.fc19.x86_64 exhibits same misbehavior
Comment 9 Steven Usdansky 2013-03-19 06:57:58 EDT
Created attachment 712563 [details]
/var/log/messages good (3.7) and bad (3.9) kernels

Shows both successful boots (kernel-3.7.9-205.fc18.x86_64) and unsuccessful boot (kernel-3.9.0-0.rc3.git0.3.fc19.x86_64) on March 19
Comment 10 Steven Usdansky 2013-03-19 07:05:25 EDT
Created attachment 712565 [details]
Xorg.0.log for failed modeset with kernel-3.9.0-0.rc3.git0.3.fc19.x86_64

Should probably obsolete attachment #704477 [details], but xorg.conf was changed to explicitly load various modules as shown below (it didn't make a difference):

Section "Module"
	Load  "dri2"
	Load  "dbe"
	Load  "glx"
	Load  "extmod"
	Load  "record"
	Load  "dri"
	Load  "fb"
	Load  "exa"
	Load  "shadowfb"
	Load  "evdev"
EndSection
Comment 11 Steven Usdansky 2013-03-23 09:46:12 EDT
Problem persists with:
kernel-3.9.0-0.rc3.git1.3.fc19.x86_64
xorg-x11-drv-nouveau-1.0.6-7.fc19.x86_64
Comment 12 Steven Usdansky 2013-04-24 09:04:41 EDT
Problem persists with kernel 3.9.0-0.rc7.git3.1.fc19.x86_64 and with the testday iso. I gave up and switched to the nvidia driver (akmod-nvidia-313.30-2.fc19.x86_64)

Note You need to log in before you can comment on or make changes to this bug.