Bug 917287 - ICE: in declare_return_variable, at tree-inline.c:2833
ICE: in declare_return_variable, at tree-inline.c:2833
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
s390x Unspecified
high Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ZedoraTracker
  Show dependency treegraph
 
Reported: 2013-03-02 12:10 EST by Dan Horák
Modified: 2013-03-05 07:00 EST (History)
2 users (show)

See Also:
Fixed In Version: gcc-4.8.0-0.15.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-05 07:00:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
preprocessed source file (290.14 KB, application/octet-stream)
2013-03-02 12:10 EST, Dan Horák
no flags Details

  None (edit)
Description Dan Horák 2013-03-02 12:10:45 EST
Created attachment 704496 [details]
preprocessed source file

building coreutils 8.21 fails with an ICE on s390/s390x

...
In function 'process_line':
cc1: internal compiler error: in declare_return_variable, at tree-inline.c:2833
Please submit a full bug report,
with preprocessed source if appropriate.


Version-Release number of selected component (if applicable):
gcc-4.8.0-0.14.fc19.s390x
Comment 1 Dan Horák 2013-03-02 12:21:07 EST
rerun with verbose output

...
gcc -std=gnu99  -I. -I./lib  -Ilib -I./lib -Isrc -I./src    -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4  -m64 -march=z9-109 -mtune=z10 -D_GNU_SOURCE=1 -fno-strict-aliasing -fpic -c -o src/numfmt.o src/numfmt.c
In function 'process_line':
cc1: internal compiler error: in declare_return_variable, at tree-inline.c:2833
Please submit a full bug report,
Comment 2 Dan Horák 2013-03-02 12:25:09 EST
and using -O1 makes the ICE go away
Comment 3 Jakub Jelinek 2013-03-05 06:09:42 EST
I couldn't reproduce this with a cross compiler, but similar ICE has been fixed recently, so please try gcc-4.8.0-0.15.fc19.
Comment 4 Dan Horák 2013-03-05 07:00:29 EST
yes, seems to be fixed, no more ICE with gcc-4.8.0-0.15.fc19

Note You need to log in before you can comment on or make changes to this bug.