This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 91739 - No way to insert/delete data in rhdb-admin.tcl
No way to insert/delete data in rhdb-admin.tcl
Status: CLOSED NOTABUG
Product: Red Hat Database
Classification: Red Hat
Component: gui (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Fernando Nasser
Permaine Cheung
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-27 15:26 EDT by P Fudd
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-27 15:39:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description P Fudd 2003-05-27 15:26:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
I'm looking at rhdb-admin, downloaded 2003-05-26 using:
cvs -d :pserver:anoncvs:anoncvs@sources.redhat.com:/cvs/rhdb co rhdb-admin
and I like the program quite a bit.

There's a problem though; while I've found how to view data (right click on a
table and pick 'view data'), I haven't found a way to insert or delete data
(apart from right clicking on the database and saying 'start shell' and doing it
by hand.)


Version-Release number of selected component (if applicable):
(Database) Administrator Version 2.0-Beta

How reproducible:
Always

Steps to Reproduce:
1.  Create a test table
2.  Try to add data with rhdb-admin
3.  Try to delete data with rhdb-admin
    

Additional info:

This is using RH9 and the postgres that comes with it.
Comment 1 Fernando Nasser 2003-05-27 15:39:12 EDT
Hi,

As the nemu option says, "View Data" is only intended to browse data in the
tables, not to update it.  We added it so that the DBA could inspect system
tables or even user tables to get a better notion of how the data looks like
(see a sample of the data in addition to the schema sometimes helps).

rhdb-admin is a management tool (DDL related) as opposed to a data access tool
(DML related).

Have you tried using OpenOffice to handle your data?

Note You need to log in before you can comment on or make changes to this bug.