Bug 917717 - Tigervnc needs versioned pixman dependency
Summary: Tigervnc needs versioned pixman dependency
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tigervnc
Version: 6.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Tim Waugh
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-04 15:59 UTC by Karel Piwko
Modified: 2014-10-14 04:39 UTC (History)
2 users (show)

Fixed In Version: tigervnc-1.1.0-13.el6
Doc Type: Bug Fix
Doc Text:
Although Xvnc uses pixman, it was possible to install incompatible versions of pixman and tigervnc-server. In this situation, Xvnc would not start due to symbol resolution failures. The tigervnc-server package now has an explicitly versioned requirement for pixman, preventing this from happening.
Clone Of:
Environment:
Last Closed: 2014-10-14 04:39:01 UTC
Target Upstream Version:


Attachments (Terms of Use)
vnc logfile (194 bytes, text/plain)
2013-03-04 17:20 UTC, Karel Piwko
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1412 normal SHIPPED_LIVE tigervnc bug fix update 2014-10-14 01:11:08 UTC

Description Karel Piwko 2013-03-04 15:59:19 UTC
Description of problem:

Xvnc refuses to start on RHEL 6.4. Most recent RHEL 6.3 with tigervnc-server does not work neither.

Version-Release number of selected component (if applicable):

tigervnc-server-1.1.0-5.el6.x86_64

How reproducible:

Always.

Steps to Reproduce:
1. Run Xvnc
  
Actual results:

vncserver :105

WARNING: The first attempt to start Xvnc failed, possibly because the font
catalog is not properly configured. Attempting to determine an appropriate
font path for this system and restart Xvnc using that font path ...
Could not start Xvnc.


/usr/bin/Xvnc: symbol lookup error: /usr/bin/Xvnc: undefined symbol: 
pixman_composite_trapezoids
/usr/bin/Xvnc: symbol lookup error: /usr/bin/Xvnc: undefined symbol: 
pixman_composite_trapezoids
Starting xvnc
[jbosstools-server_41] $ vncserver :106

WARNING: The first attempt to start Xvnc failed, possibly because the font
catalog is not properly configured. Attempting to determine an appropriate
font path for this system and restart Xvnc using that font path ...
Could not start Xvnc.

/usr/bin/Xvnc: symbol lookup error: /usr/bin/Xvnc: undefined symbol: 
pixman_composite_trapezoids
/usr/bin/Xvnc: symbol lookup error: /usr/bin/Xvnc: undefined symbol: 
pixman_composite_trapezoids
Starting xvnc

Expected results:

It starts.

Additional info:

Works when downgraded:

tigervnc-server.x86_64 0:1.0.90-0.10.20100115svn3945.el6

Comment 2 Adam Tkac 2013-03-04 17:06:36 UTC
I'm not able to reproduce this issue. Can you please attach Xvnc's ~/.vnc/<hostname>:106.log file?

Which version of "pixman" package do you have?

Thank you in advance for response.

Comment 3 Karel Piwko 2013-03-04 17:20:52 UTC
Created attachment 705084 [details]
vnc logfile

Attaching log, it does not contain anything useful.

Pixman version is pixman-0.18.4-1.el6_0.1.i686.

Comment 4 Karel Piwko 2013-03-04 17:23:44 UTC
Note, that log comes from dev107, which might contains tigervnc-server-1.1.0-5.el6.i686 version. Both 32bit and 64bit packagings are affected.

Comment 5 Adam Tkac 2013-03-04 17:38:00 UTC
(In reply to comment #3)
> Created attachment 705084 [details]
> vnc logfile
> 
> Attaching log, it does not contain anything useful.
> 
> Pixman version is pixman-0.18.4-1.el6_0.1.i686.

This is obvious misconfiguration on affected system. You picked up tigervnc from RHEL-6.4 but your pixman comes from RHEL-6.3.z. Please fix your system and install all relevant RHEL-6.4 updates, including pixman-0.26.2-4.el6.x86_64. Or stick with RHEL-6.3.z and install both pixman and tigervnc shipped in RHEL-6.3. Mixing of different RHEL-6 channels (RHEL-6.3.z and RHEL-6.4 in this case) is not supported.

Closing as notabug.

Comment 6 Karel Piwko 2013-03-05 10:57:40 UTC
Reopening, adding a feedback from eng-ops:

We install software from the standard RHEL channels derived from RHN.

Let's assume we're on a RHEL 6.3 system using standard RHEL software channels
including updates.

Let's assume further we've got a working version of tigervnc-server installed
(and a matching pixman version respectively):

<snip>

[root@dev87 ~]# rpm -qa tigervnc-server\*
tigervnc-server-1.0.90-0.10.20100115svn3945.el6.i686
tigervnc-server-module-1.1.0-5.el6.i686
[root@dev87 ~]# rpm -qa pixman\*
pixman-0.18.4-1.el6_0.1.i686

<snap>

Now let's assume we want to update the installed tigervnc-server version (see above) to the latest
available using the standard RHEL software channels:

<snip>

[root@dev87 ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 6.3 (Santiago)
[root@dev87 ~]# yum clean all
Loaded plugins: downloadonly, fastestmirror
Cleaning repos: Eng-systems Eng-systems-noarch Fastrack JBossQASystems
Show quoted text
Cleaning up Everything

[root@dev87 ~]# yum upgrade tigervnc-server\*
Loaded plugins: downloadonly, fastestmirror
Loading mirror speeds from cached hostfile
* Fastrack: download.eng.bos.redhat.com
* Optional: download.eng.bos.redhat.com
* Server: download.eng.bos.redhat.com
* Updates: download.eng.bos.redhat.com
Setting up Upgrade Process
Resolving Dependencies
--> Running transaction check
---> Package tigervnc-server.i686 0:1.0.90-0.10.20100115svn3945.el6 will be updated
---> Package tigervnc-server.i686 0:1.1.0-5.el6 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
Package Arch Version Repository Size
================================================================================
Updating:
tigervnc-server i686 1.1.0-5.el6 Updates 1.1 M

Transaction Summary
================================================================================
Upgrade 1 Package(s)

Total download size: 1.1 M
Is this ok [y/N]: y
Downloading Packages:
tigervnc-server-1.1.0-5.el6.i686.rpm | 1.1 MB 00:00 
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Updating : tigervnc-server-1.1.0-5.el6.i686 1/2 
Cleanup : tigervnc-server-1.0.90-0.10.20100115svn3945.el6.i686 2/2 
Verifying : tigervnc-server-1.1.0-5.el6.i686 1/2 
Verifying : tigervnc-server-1.0.90-0.10.20100115svn3945.el6.i686 2/2 

Updated:
tigervnc-server.i686 0:1.1.0-5.el6 

<snap>

However, 

<snip>

[root@dev87 ~]# rpm -qa pixman\*
pixman-0.18.4-1.el6_0.1.i686

<snap>

As you can see, tigervnc-server got updated to 1.1.0, however, pixman didn't. If tigervnc-server requires
a pixman version >= 0.26 it should've pulled in and upgraded pixman as a dependency (tigervnc-server RPM
SPEC file, "Requires pixman >= 0.26.2"). There is no such reference in the tigervnc-server-1.1.0-5 RPM [1].

If tigervnc from RHEL-6.4 got installed on a RHEL 6.3 system then obviously there is something wrong with 
the upstream software channels which would have to be investigated by Release Engineering.

I will manually upgrade pixman on all RHEL 6 Jenkins slaves so the latest Xvnc based on tigervnc-server-1.1.0-5 
will hopefully work again.

Timo

[1] http://download.devel.redhat.com/brewroot/packages/tigervnc/1.1.0/5.el6/src/tigervnc-1.1.0-5.el6.src.rpm [Open URL]

Comment 7 Karel Piwko 2013-03-05 10:58:53 UTC
Note, I lowered the priority to medium as you have identified a workaround.

Comment 8 Adam Tkac 2013-03-05 11:09:17 UTC
Ok, I will add the versioned pixman dependency in the next tigervnc update.

Comment 10 RHEL Program Management 2013-10-13 23:53:07 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Comment 17 errata-xmlrpc 2014-10-14 04:39:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1412.html


Note You need to log in before you can comment on or make changes to this bug.