Bug 917735 - coreutils fails to build for aarch64
coreutils fails to build for aarch64
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
rawhide
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-04 11:38 EST by Mark Salter
Modified: 2013-03-04 12:24 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-04 12:24:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to fix aarch64 bits of longlong.h (1.57 KB, patch)
2013-03-04 11:38 EST, Mark Salter
no flags Details | Diff

  None (edit)
Description Mark Salter 2013-03-04 11:38:37 EST
Created attachment 705066 [details]
Patch to fix aarch64 bits of longlong.h

Description of problem:

coreutils fails to build src/factor.c for AArch64 because of a problem with longlong.h

The longlong.h problem was fixed upstream in gmp:

  http://gmplib.org:8000/gmp/rev/187b7b1646ee

Patch attached.

Version-Release number of selected component (if applicable):


How reproducible:

100%

Steps to Reproduce:
1. build coreutils for aarch64
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Ondrej Vasik 2013-03-04 12:24:07 EST
Commited and built, closing RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.