Bug 91776 - Typing degree sign or other iso-transl symbols in GNU Emacs causes Emacs to lock up
Typing degree sign or other iso-transl symbols in GNU Emacs causes Emacs to l...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: emacs (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-27 19:42 EDT by Dan Reish
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-14 02:51:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Reish 2003-05-27 19:42:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
Typing an ISO degree sign in Emacs (with C-x 8 o) in fundamental mode or in text
mode (and probably others), instead of inserting the degree symbol, causes Emacs
to display the degree symbol in the message buffer followed by a dash, as if it
was supposed to be some sort of prefix command.

At work, I use a locally-compiled GNU Emacs 21 (not sure offhand of the exact
version) under Solaris, and "C-x 8 o" inserts the degree symbol as documented.

I've tried a couple of other C-x 8 ISO sequences under RH9's GNU Emacs, and they
all produce the same effect.

There's an additional quirk I observe when I use my .emacs file.  (Of course, I
tried emacs -q to make sure it was reproducible under a default installation;
the bug still happens).  I use type-break-mode, and when I enter C-x 8 o, and
then hit a couple of other keys, the counter "Warning: typing break due in N
keystrokes." counts down rapidly to negative numbers just before Emacs freezes.

Depending on whether or not focus has been shifted away from the Emacs window,
Emacs is either locked up hard, and no longer even redraws in the former case,
or is just lost in thought and can be arrested with a C-g.



Version-Release number of selected component (if applicable):
emacs-21.2-33

How reproducible:
Always

Steps to Reproduce:
1. emacs [Enter]
2. Press Ctrl-X, then "8", then "o"
3. Wait a second, observe the degree symbol in the wrong buffer
4. Press any other keys until Emacs has locked up
5. To get it running again, Press Ctrl-G, or to make it lock up hard, give
another window focus momentarily, after which switching to another workspace and
back leaves the Emacs window only partially redrawn.


Expected Results:  A degree symbol (�) should be inserted.


Additional info:

"C-x 8 ~ SPC" successfully inserts a "~".

Emacs under RH9 also seems to have issues with getting non-ASCII characters
pasted in from the Character Map app, even when they correspond to normal 8-bit
ISO-whatever characters.  Some of them work, and some of them don't.  The
behavior appears to be very strange and inconsistent.
Comment 1 Jens Petersen 2003-05-27 22:43:29 EDT
What locale are you using?

I only see something like what you describe in ja_JP.eucJP locale,
where `C-x 8 o' is bound to something else. 

Can you try updating to the emacs-21.3 in rawhide and see if
the problem goes away for you there?
Comment 2 Dan Reish 2003-05-28 08:15:03 EDT
% set
LANG=en_US.UTF-8

I think this was the installation default.  At least, I don't remember changing
any language settings during installation or after.

Running Emacs like this:

LANG=en_US.ISO-8859-1 emacs &

Appears to fix the problem.  I only tried one symbol (the degree sign) before I
had to run off to work, but I suspect this fixes all of them.  The same solution
was proposed for some severe display problems I had with gnumeric.  (Bug 89761.)

Perhaps gnumeric and emacs (no doubt among others) should ship with a wrapper
which checks for problematic locales.
Comment 3 Jens Petersen 2003-10-27 08:17:54 EST
This works fine the latest emacs packages afaict.  Could you please
one of those?  Thanks.

Note You need to log in before you can comment on or make changes to this bug.