Bug 91778 - "gzip -l" reports incorrect uncompressed size on files > 4gb
Summary: "gzip -l" reports incorrect uncompressed size on files > 4gb
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gzip (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-28 00:57 UTC by Steve Bonds
Modified: 2016-05-07 11:59 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-07 11:59:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Steve Bonds 2003-05-28 00:57:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314

Description of problem:
When running "gzip -l" on files larger than 4gb, the reported size is the actual
size minus 4gb.  (I didn't test on files > 8gb.)  The files are correct and
valid, but the reported uncompressed size is wrong.

Version-Release number of selected component (if applicable):
gzip-1.3.3-1

How reproducible:
Always

Steps to Reproduce:
1. Create a file larger than 4gb (i.e. dd bs=1024M if=/dev/null seek=5
of=/tmp/sparse.bin)
2. Compress it (i.e. gzip --fast -c /tmp/sparse.bin > /tmp/sparse.bin.gz)
3. Run "gzip -l" on the file (i.e. "gzip -l /tmp/sparse.bin.gz")
    

Actual Results:  "gzip -l /tmp/sparse.bin.gz" reports:

         compressed        uncompressed  ratio uncompressed_name
           23418688          1073741824  97.8% sparse.bin


Expected Results:  "gzip -l /tmp/sparse.bin.gz" should have reported:

         compressed        uncompressed  ratio uncompressed_name
           23418688          5368709120  99.6% sparse.bin


Additional info:

Comment 1 Steve Bonds 2003-05-28 15:11:58 UTC
I just received this message from the author:

-----
This is due to an unfortunate limitation of the gzip 1.x file format:
the uncompressed size is stored on 4 bytes only. This will be fixed
in a future version of gzip.

Jean-loup
-----


Comment 2 Fedora Update System 2016-04-22 05:07:26 UTC
libreoffice-5.1.3.1-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-416f593172

Comment 3 Fedora Update System 2016-04-23 21:23:40 UTC
libreoffice-5.1.3.1-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-416f593172

Comment 4 Fedora Update System 2016-05-07 11:59:56 UTC
libreoffice-5.1.3.1-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.