Bug 91791 - Glibc 2.3.2-27.9 source rpm doesn't build properly
Summary: Glibc 2.3.2-27.9 source rpm doesn't build properly
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc
Version: 9
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-28 10:33 UTC by Bill
Modified: 2016-11-24 15:05 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2003-05-28 10:37:03 UTC


Attachments (Terms of Use)

Description Bill 2003-05-28 10:33:04 UTC
Description of problem: 
When building glibc 2.3.2-27.9 with target athlon, it only produces two rpms: 
glibc-2.3.2-27.9.athlon.rpm (30,089,187 bytes) and nptl-devel-2.3.2-27.9.athlon.rpm 
(814,528 bytes). 
 
Version-Release number of selected component (if applicable): 
glibc 2.3.2-27.9 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1. Download glibc-2.3.2-27.9.src.rpm from Red Hat 
2. build for target athlon 
     
Actual results: 
Produces two files: glibc-2.3.2-27.9.athlon.rpm (30,089,187 bytes) and 
nptl-devel-2.3.2-27.9.athlon.rpm (814,528 bytes). 
 
Expected results: 
Should produce eight files: glibc-2.3.2-27.9.athlon.rpm, 
glibc-common-2.3.2-27.9.athlon.rpm, glibc-debug-2.3.2-27.9.athlon.rpm, 
glibc-devel-2.3.2-27.9.athlon.rpm, glibc-profile-2.3.2-27.9.athlon.rpm, 
glibc-utils-2.3.2-27.9.athlon.rpm, nptl-devel-2.3.2-27.9.athlon.rpm and 
nscd-2.3.2-27.9.athlon.rpm 
 
Additional info: 
glibc-2.3.2-27.9.src.rpm was downloaded from https://rhn.redhat.com, is 12,970,246 
bytes, and has the md5sum 7cef2cd488a94ff21bfc25d4c0099d67.

Comment 1 Jakub Jelinek 2003-05-28 10:37:03 UTC
It should not, .i386.rpm packages should be used for those not built for .i686/.athlon.
This is for 2 reasons: 1) some files are identical, so there is no need to
duplicate them (e.g. most of glibc-common, etc.) 2) for -static link, it is
desirable to always provide just the .i386.rpm static libraries, so binaries
can run even on older processors.
If you don't like this, you can tweak %auxarches macro at start of glibc.spec,
but we are not going to change the default for the reasons stated above.


Note You need to log in before you can comment on or make changes to this bug.