Bug 91792 - Tomcat cannot listen on low ports
Tomcat cannot listen on low ports
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: tomcat (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gary Benson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-28 06:38 EDT by Gary Benson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-03 05:10:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gary Benson 2003-05-28 06:38:18 EDT
Description of problem:
Because tomcat runs as a non-root user it cannot listen on low ports.

Additional info:
It might be possible to do a wrapper which handles the setuid/setgid bit but
retains the capability to bind to low ports.
Comment 1 Gary Benson 2003-06-04 12:10:17 EDT
tomcat-4.1.24-5 has hooks in daemon.c where capabilities code could be added.

Note You need to log in before you can comment on or make changes to this bug.