Bug 91845 - bug in scroll_to_cell
bug in scroll_to_cell
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: gtk2 (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-28 17:07 EDT by Brent Fox
Modified: 2007-04-18 12:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-13 16:31:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
demonstration of scrolling bug (870 bytes, text/plain)
2003-05-28 17:08 EDT, Brent Fox
no flags Details

  None (edit)
Description Brent Fox 2003-05-28 17:07:28 EDT
If the value in a gtkTreeView is too wide for the display, calling
scroll_to_cell() will cause the Tree View to start moving horizontally, which is
not supposed to happen.  I'm filing this against pygtk2 since that's what I'm
using, but the bug could well be in gtk2.

I'm attaching a sample program to demonstrate the behavior.  Just start clicking
the "clickme" button and see the tree start scrolling horizontally.
Comment 1 Brent Fox 2003-05-28 17:08:05 EDT
Created attachment 92040 [details]
demonstration of scrolling bug
Comment 2 Matt Wilson 2003-10-09 18:46:03 EDT
gtk bug.
Comment 3 Owen Taylor 2003-10-09 18:57:09 EDT
Really looks like NOTABUG to me but assigning it Jonathan since he'll know
for sure - you pass in a column and a horizontal align of 0.5:

http://developer.gnome.org/doc/API/2.0/gtk/GtkTreeView.html#gtk-tree-view-scroll-to-cell

says "If column is NULL, then no horizontal scrolling occurs", so if you
don't want horizontal scrolling, then you should pass in 'None' instead of
'col'
Comment 4 Matthias Clasen 2004-05-12 17:31:23 EDT
The bug is that it keeps on scrolling to the left every time you click
on the button.
Comment 5 Matthias Clasen 2004-05-13 16:31:56 EDT
Filed upstream as http://bugzilla.gnome.org/show_bug.cgi?id=142494
with some analysis.

Note You need to log in before you can comment on or make changes to this bug.