Bug 918460 - semanage boolean -m BOOLEAN_NAME tracebacks
Summary: semanage boolean -m BOOLEAN_NAME tracebacks
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: policycoreutils
Version: 6.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Daniel Walsh
QA Contact: Michal Trunecka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-06 09:42 UTC by Milos Malik
Modified: 2018-08-02 07:49 UTC (History)
4 users (show)

Fixed In Version: policycoreutils-2.0.83-19.34.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-11-21 11:07:37 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1608 normal SHIPPED_LIVE policycoreutils bug fix and enhancement update 2013-11-20 21:39:06 UTC

Description Milos Malik 2013-03-06 09:42:27 UTC
Description of problem:
The same problem as described in BZ#918140 appears on RHEL-6.4 too.

Version-Release number of selected component (if applicable):
policycoreutils-python-2.0.83-19.30.el6.i686
policycoreutils-gui-2.0.83-19.30.el6.i686
policycoreutils-2.0.83-19.30.el6.i686
policycoreutils-newrole-2.0.83-19.30.el6.i686

How reproducible:
always

Steps to Reproduce:
# semanage boolean -m xen_use_nfs
Traceback (most recent call last):
  File "/usr/sbin/semanage", line 564, in <module>
    process_args(sys.argv[1:])
  File "/usr/sbin/semanage", line 442, in process_args
    OBJECT.modify(target, value, use_file)
  File "/usr/lib/python2.6/site-packages/seobject.py", line 2060, in modify
    self.__mod(name, value)
  File "/usr/lib/python2.6/site-packages/seobject.py", line 2027, in __mod
    if value.upper() in self.dict:
AttributeError: 'NoneType' object has no attribute 'upper'
# echo $?
1
#

Actual results:
 * a traceback

Expected results:
 * either specified action is done or an error message "you forgot to specify ..." is displayed

Comment 1 Miroslav Grepl 2013-09-05 10:20:54 UTC
Ok, I have a RHEL6 patch for this issue.

Comment 2 RHEL Program Management 2013-09-05 10:40:43 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.

Comment 5 errata-xmlrpc 2013-11-21 11:07:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1608.html


Note You need to log in before you can comment on or make changes to this bug.