Bug 918478 - [hi_IN] Droid Sans Devanagari preferred over Lohit Devanagari for Devangari script when google-droid-sans-fonts installed
[hi_IN] Droid Sans Devanagari preferred over Lohit Devanagari for Devangari s...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lohit-devanagari-fonts (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-06 05:37 EST by A S Alam
Modified: 2013-07-02 21:13 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-01 18:35:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description A S Alam 2013-03-06 05:37:02 EST
Description of problem:
while using libreoffice and get google-droid installed on machine, libreoffice pick default "Droid Sans Devanagari" instead of lohit.

Version-Release number of selected component (if applicable):
google-droid-sans-fonts-20120715-4.fc18.noarch
lohit-devanagari-fonts-2.5.3-1.fc18.noarch
libreoffice-core-3.6.5.2-5.fc18.x86_64
libicu-49.1.1-5.fc18.x86_64


How reproducible:
Everytime

Steps to Reproduce:
1. install google-droid* fonts
2.$LANG=hi_IN.UTF-8 oowriter
3. Check default selected fonts
  
Actual results:
it is "Droid Sans Devanagari"

Expected results:
it should be "Lohit Devanagari"

Additional info:
Rendering is not good as lohit for Devanagari (like (कड़ियाँ) character is rendered bad in droid font)
Comment 1 Caolan McNamara 2013-03-06 07:01:05 EST
What does:
fc-match "Lohit Hindi"
say ?
Comment 2 Caolan McNamara 2013-03-06 07:19:48 EST
Little test case here...
$ yum -y install google-droid-sans-fonts lohit-devanagari-fonts
$ LANG=hi_IN fc-match "foo"
DroidSansDevanagari-Regular.ttf: "Droid Sans" "Regular"
$ mv /etc/fonts/conf.d/65-google-droid-sans.conf /etc/fonts/conf.d/67-google-droid-sans.conf
$ LANG=hi_IN fc-match "foo"
Lohit-Devanagari.ttf: "Lohit Devanagari" "Regular"

so with our default congigs fontconfig prefers "Droid Sans" to "Lohit Devanagari" for hi_IN when both are available. So if Lohit is better than Droid it should be a higher priority. One way (I believe) is to give its config a lower number than that of Droid. Presumably there are a bunch of other ways to do this, so moving to the fontconfig maintainer to indicate the right way to resolve that.
Comment 3 Akira TAGOH 2013-03-06 22:59:37 EST
There are nothing I can do in fontconfig for this issue... those recipes in question is in google-droid-fonts.

FWIW as you pointed out, this is just a priority issue in that case:

$ FC_DEBUG=3 LANG=hi_IN fc-match foo
Font 28 Pattern has 20 elts (size 20)
        family: "Lohit Devanagari"(w)
...
 family: 87  "foo"(s) "DejaVu Sans"(w) "PT Sans"(w) "Bitstream Vera Sans"(w) "DejaVu Sans"(w) "Verdana"(w) "Arial"(w) "Albany AMT"(w) "Luxi Sans"(w) "Nimbus Sans L"(w) "Helvetica"(w) "Lucida Sa
ns Unicode"(w) "BPG Glaho International"(w) "Tahoma"(w) "Dustismo"(w) "Droid Sans"(w) "Nachlieli"(w) "Lucida Sans Unicode"(w) "Yudit Unicode"(w) "Kerkis"(w) "ArmNet Helvetica"(w) "Artsounk"(w) 
"BPG UTF8 M"(w) "Waree"(w) "Loma"(w) "Garuda"(w) "Umpush"(w) "Saysettha Unicode"(w) "JG Lao Old Arial"(w) "GF Zemen Unicode"(w) "Pigiarniq"(w) "B Davat"(w) "B Compset"(w) "Kacst-Qr"(w) "Urdu Na
staliq Unicode"(w) "Raghindi"(w) "Mukti Narrow"(w) "malayalam"(w) "Sampige"(w) "padmaa"(w) "Hapax Berbère"(w) "MS Gothic"(w) "UmePlus P Gothic"(w) "SimSun"(w) "PMingLiu"(w) "WenQuanYi Zen Hei"
w) "WenQuanYi Bitmap Song"(w) "AR PL ShanHeiSun Uni"(w) "AR PL New Sung"(w) "MgOpen Modata"(w) "VL Gothic"(w) "IPAMonaGothic"(w) "IPAGothic"(w) "Sazanami Gothic"(w) "Kochi Gothic"(w) "AR PL Kai
tiM GB"(w) "AR PL KaitiM Big5"(w) "AR PL ShanHeiSun Uni"(w) "AR PL SungtiL GB"(w) "AR PL Mingti2L Big5"(w) "MS ゴシック"(w) "ZYSong18030"(w) "TSCu_Paranar"(w) "NanumGothic"(w) "UnDotum"(w) "B
aekmuk Dotum"(w) "Baekmuk Gulim"(w) "KacstQura"(w) "Lohit Bengali"(w) "Lohit Gujarati"(w) "Lohit Hindi"(w) "Lohit Marathi"(w) "Lohit Maithili"(w) "Lohit Kashmiri"(w) "Lohit Konkani"(w) "Lohit N
epali"(w) "Lohit Sindhi"(w) "Lohit Punjabi"(w) "Lohit Tamil"(w) "Meera"(w) "Lohit Malayalam"(w) "Lohit Kannada"(w) "Lohit Telugu"(w) "Lohit Oriya"(w) "LKLUG"(w) "Padauk"(w) "Lohit Devanagari"(w
) "FreeSans"(w) "FreeSans"(w) "Arial Unicode MS"(w) "Arial Unicode"(w) "Code2000"(w) "Code2001"(w) "sans-serif"(w) "Roya"(w) "Koodak"(w) "Terafik"(w) "foo"(w) "sans-serif"(w) "sans-serif"(w) "s
ans-serif"(w) "sans-serif"(w) "sans-serif"(w) "sans-serif"(w) "sans-serif"(w) "sans-serif"(w) "sans-serif"(w) "sans-serif"(w),  "Lohit Devanagari"(w)
 slant: 1  0(i)(s),  0(i)(w)
 weight: 20001  100(i)(s),  80(i)(w)
 width: 1  100(i)(s),  100(i)(w)
 lang: 1  "hi"(w),  bh|bho|hi|kok|mr|ne|sa|hne|mai|brx|sat|doi(w)
 fontversion: 2.14732e+12  2147483647(i)(s),  163840(i)(w)
 decorative: 1  FcFalse(s),  FcFalse(w)
Score 0 0 0 1001 1 87 0 0 0 1 20001 1 1 0 0 0 2.14732e+12

...

Font 84 Pattern has 20 elts (size 20)
        family: "Droid Sans"(w)
...
        file: "/usr/share/fonts/google-droid/DroidSansDevanagari-Regular.ttf"(w)
...
 family: 16  "foo"(s) "DejaVu Sans"(w) "PT Sans"(w) "Bitstream Vera Sans"(w) "DejaVu Sans"(w) "Verdana"(w) "Arial"(w) "Albany AMT"(w) "Luxi Sans"(w) "Nimbus Sans L"(w) "Helvetica"(w) "Lucida Sa
ns Unicode"(w) "BPG Glaho International"(w) "Tahoma"(w) "Dustismo"(w) "Droid Sans"(w) "Nachlieli"(w) "Lucida Sans Unicode"(w) "Yudit Unicode"(w) "Kerkis"(w) "ArmNet Helvetica"(w) "Artsounk"(w) 
"BPG UTF8 M"(w) "Waree"(w) "Loma"(w) "Garuda"(w) "Umpush"(w) "Saysettha Unicode"(w) "JG Lao Old Arial"(w) "GF Zemen Unicode"(w) "Pigiarniq"(w) "B Davat"(w) "B Compset"(w) "Kacst-Qr"(w) "Urdu Na
staliq Unicode"(w) "Raghindi"(w) "Mukti Narrow"(w) "malayalam"(w) "Sampige"(w) "padmaa"(w) "Hapax Berbère"(w) "MS Gothic"(w) "UmePlus P Gothic"(w) "SimSun"(w) "PMingLiu"(w) "WenQuanYi Zen Hei"
w) "WenQuanYi Bitmap Song"(w) "AR PL ShanHeiSun Uni"(w) "AR PL New Sung"(w) "MgOpen Modata"(w) "VL Gothic"(w) "IPAMonaGothic"(w) "IPAGothic"(w) "Sazanami Gothic"(w) "Kochi Gothic"(w) "AR PL Kai
tiM GB"(w) "AR PL KaitiM Big5"(w) "AR PL ShanHeiSun Uni"(w) "AR PL SungtiL GB"(w) "AR PL Mingti2L Big5"(w) "MS ゴシック"(w) "ZYSong18030"(w) "TSCu_Paranar"(w) "NanumGothic"(w) "UnDotum"(w) "B
aekmuk Dotum"(w) "Baekmuk Gulim"(w) "KacstQura"(w) "Lohit Bengali"(w) "Lohit Gujarati"(w) "Lohit Hindi"(w) "Lohit Marathi"(w) "Lohit Maithili"(w) "Lohit Kashmiri"(w) "Lohit Konkani"(w) "Lohit N
epali"(w) "Lohit Sindhi"(w) "Lohit Punjabi"(w) "Lohit Tamil"(w) "Meera"(w) "Lohit Malayalam"(w) "Lohit Kannada"(w) "Lohit Telugu"(w) "Lohit Oriya"(w) "LKLUG"(w) "Padauk"(w) "Lohit Devanagari"(w
) "FreeSans"(w) "FreeSans"(w) "Arial Unicode MS"(w) "Arial Unicode"(w) "Code2000"(w) "Code2001"(w) "sans-serif"(w) "Roya"(w) "Koodak"(w) "Terafik"(w) "foo"(w) "sans-serif"(w) "sans-serif"(w) "s
ans-serif"(w) "sans-serif"(w) "sans-serif"(w) "sans-serif"(w) "sans-serif"(w) "sans-serif"(w) "sans-serif"(w) "sans-serif"(w),  "Droid Sans"(w)
 slant: 1  0(i)(s),  0(i)(w)
 weight: 20001  100(i)(s),  80(i)(w)
 width: 1  100(i)(s),  100(i)(w)
 lang: 1  "hi"(w),  bh|bho|hi|kok|mr|ne|sa|hne|mai|brx|sat|doi(w)
 fontversion: 2.14748e+12  2147483647(i)(s),  6(i)(w)
 decorative: 1  FcFalse(s),  FcFalse(w)
Score 0 0 0 1001 1 16 0 0 0 1 20001 1 1 0 0 0 2.14748e+12

less score has a priority and Droid Sans has 16 in family name which is less than 87 for Lohit.
this is the reason why fontconfig chooses Droid Sans rather than Lohit.
Comment 4 Nicolas Mailhot 2013-03-07 12:44:23 EST
I can change the droid prio, but 65 was supposed to be "safe" for general purpose i18n fonts and the cjk font packages chose settings that are higher prio than droid. Why is lohit not doing the same? Is there a specific problem that does not apply to cjk fonts?
Comment 5 Pravin Satpute 2013-03-08 00:46:18 EST
Sure, I will change Lohit-Devanagari priority to 65-0. I think i missed this change last time.

Moving component to lohit-devanagari
Comment 6 Akira TAGOH 2013-03-08 01:59:43 EST
Hmm, that said this way was a sort of hack to get a little higher priority than 65. ideally this should be sorted out one day. or if it's a bit hard to maintain recipes - including priorities - in each font packages, we may try to have centralized packages to maintain them perhaps. that would makes easier to create the default font table per languages too.
Comment 7 Pravin Satpute 2013-03-14 01:51:24 EDT
Yes agree, but this will distro specific, right?
Comment 8 Fedora Update System 2013-03-14 01:59:38 EDT
lohit-devanagari-fonts-2.5.3-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/lohit-devanagari-fonts-2.5.3-2.fc18
Comment 9 Fedora Update System 2013-03-14 20:08:33 EDT
Package lohit-devanagari-fonts-2.5.3-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lohit-devanagari-fonts-2.5.3-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-3866/lohit-devanagari-fonts-2.5.3-2.fc18
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2013-04-01 18:35:35 EDT
lohit-devanagari-fonts-2.5.3-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.