Bug 918646 - xfdesktop gets stuck.
xfdesktop gets stuck.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xfdesktop (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-06 11:30 EST by Dave Jones
Modified: 2015-01-04 17:32 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-31 23:27:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Xfce 9892 None None None Never

  None (edit)
Description Dave Jones 2013-03-06 11:30:09 EST
My desktop background is all grey, and never renders the actual background image.

top shows xfdesktop running constantly using up all cpu.

gdb backtrace shows it's stuck here..

Program received signal SIGINT, Interrupt.
0x0000003566006cda in gdk_pixbuf_get_type () at gdk-pixbuf.c:139
139	G_DEFINE_TYPE_WITH_CODE (GdkPixbuf, gdk_pixbuf, G_TYPE_OBJECT,
(gdb) bt
#0  0x0000003566006cda in gdk_pixbuf_get_type () at gdk-pixbuf.c:139
#1  0x00000035660071c9 in gdk_pixbuf_get_has_alpha (pixbuf=pixbuf@entry=0x8ef400 [GdkPixbuf]) at gdk-pixbuf.c:503
#2  0x00000035660102a8 in gdk_pixbuf_copy_area (src_pixbuf=src_pixbuf@entry=0x8ccf70 [GdkPixbuf], src_x=src_x@entry=0, src_y=src_y@entry=0, width=0, height=<optimized out>, 
    dest_pixbuf=dest_pixbuf@entry=0x8ef400 [GdkPixbuf], dest_x=0, dest_y=0) at gdk-pixbuf-util.c:156
#3  0x000000000041706f in xfce_backdrop_get_pixbuf (backdrop=backdrop@entry=0x8e9590 [XfceBackdrop]) at xfce-backdrop.c:1022
#4  0x0000000000418001 in backdrop_changed_cb (backdrop=0x8e9590 [XfceBackdrop], user_data=user_data@entry=0x8c8020) at xfce-desktop.c:338
#5  0x00000000004184e8 in screen_size_changed_cb (gscreen=0x8a4000 [GdkScreenX11], user_data=0x8c8020) at xfce-desktop.c:441
#6  0x00000000004186d5 in xfce_desktop_monitors_changed (gscreen=<optimized out>, user_data=user_data@entry=0x8c8020) at xfce-desktop.c:518
#7  0x00000000004193c5 in xfce_desktop_realize (widget=<optimized out>) at xfce-desktop.c:821
#8  0x00000033ada0fbd7 in _g_closure_invoke_va (closure=closure@entry=0x8ba710, return_value=return_value@entry=0x0, instance=instance@entry=0x8c8020, args=args@entry=
    0x7fffeb01f118, n_params=0, param_types=0x0) at gclosure.c:840
#9  0x00000033ada283a8 in g_signal_emit_valist (instance=0x8c8020, signal_id=<optimized out>, detail=0, var_args=var_args@entry=0x7fffeb01f118) at gsignal.c:3211
#10 0x00000033ada28de2 in g_signal_emit (instance=instance@entry=0x8c8020, signal_id=<optimized out>, detail=detail@entry=0) at gsignal.c:3356
#11 0x00000035238893bd in IA__gtk_widget_realize (widget=widget@entry=0x8c8020 [XfceDesktop]) at gtkwidget.c:3561
#12 0x0000003523894c20 in gtk_window_show (widget=0x8c8020 [XfceDesktop]) at gtkwindow.c:4532
#13 0x00000033ada0fbd7 in _g_closure_invoke_va (closure=closure@entry=0x8ba250, return_value=return_value@entry=0x0, instance=instance@entry=0x8c8020, args=args@entry=
    0x7fffeb01f578, n_params=0, param_types=0x0) at gclosure.c:840
#14 0x00000033ada283a8 in g_signal_emit_valist (instance=0x8c8020, signal_id=<optimized out>, detail=0, var_args=var_args@entry=0x7fffeb01f578) at gsignal.c:3211
#15 0x00000033ada28de2 in g_signal_emit (instance=instance@entry=0x8c8020, signal_id=<optimized out>, detail=detail@entry=0) at gsignal.c:3356
#16 0x000000352388a576 in IA__gtk_widget_show (widget=0x8c8020 [XfceDesktop]) at gtkwidget.c:3243
#17 IA__gtk_widget_show (widget=0x8c8020 [XfceDesktop]) at gtkwidget.c:3234
#18 0x0000000000412c6c in main (argc=1, argv=0x7fffeb01fd28) at main.c:376


It's almost as if it thinks the screen size is constantly changing (it isn't).

Changing the background settings in the display config tool don't make any difference.
Comment 1 Kevin Fenzi 2013-03-06 12:07:35 EST
rpm -q xfdesktop ?

Did it used to work? Can you pinpoint any changes?
Comment 2 Dave Jones 2013-03-06 12:27:55 EST
xfdesktop-4.10.1-1.fc18.x86_64

yeah, it broke in the last week or so.
(possibly a slightly earlier, as I've been suspend/resuming this laptop for a while).
Comment 3 Dave Jones 2013-03-06 12:30:09 EST
I did...

yum downgrade xfdesktop ; killall xfdesktop

and now it works again.

so something in between 4.10.0-4 and 4.10.1-1
Comment 4 Kevin Fenzi 2013-03-06 12:34:43 EST
This seems to be: https://bugzilla.xfce.org/show_bug.cgi?id=9892

which only hits when you have a solid background and no background image. ;) 
(I have an image here, so thats why I didn't hit it). 

I'll look at pushing a build with the patch from upstream today... 

Thanks.
Comment 5 Dave Jones 2013-03-06 12:37:34 EST
that sounds about right. I have a vertical gradient.
Comment 6 Fedora Update System 2013-03-06 16:02:40 EST
xfdesktop-4.10.1-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/xfdesktop-4.10.1-2.fc18
Comment 7 Dave Jones 2013-03-07 15:34:13 EST
yep, that does the trick.  Thanks Kevin.
Comment 8 Fedora Update System 2013-03-07 18:59:28 EST
Package xfdesktop-4.10.1-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xfdesktop-4.10.1-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-3526/xfdesktop-4.10.1-2.fc18
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2013-03-10 12:47:03 EDT
xfdesktop-4.10.2-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/xfdesktop-4.10.2-1.fc18
Comment 10 Fedora Update System 2013-03-31 23:27:59 EDT
xfdesktop-4.10.2-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.