Bug 91866 - flag screensaver combined with nvidia TNT2 bin driver
flag screensaver combined with nvidia TNT2 bin driver
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: xscreensaver (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-28 23:04 EDT by Felipe Pereira
Modified: 2014-03-16 22:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-28 23:27:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Felipe Pereira 2003-05-28 23:04:44 EDT
Description of problem:

X goes to 99% CPU (mouse moves, keyboard does not respond). Then user must (and
can) use ssh and kill X.

I'm using nvidia's own driver. I guess I should not post bugs in this case since
the kernel is tainted.


Version-Release number of selected component (if applicable):

Flag: from the XScreenSaver 4.05 distribution (28-May-2002.)


How reproducible:
Always I choose this screensaver in the properties dialog (occurs when it's
executed normally as screen saver also).

Steps to Reproduce:
1. Have nvidia's driver for TNT2
2. Execute flag (or choose it in the XScreensaver's properties dialog)
    
Actual results:
X stops. Keyboard does not respond. Mouse moves but does not click. Can't get
off X (Ctrl+Alt+F1 etc.). Must use ssh and kill X.

Expected results:
I'd expect nvidia give away the source code for this driver... I guess the
problem is with the driver.

Additional info:
I dont know how to get more info on this bug... I don't get any message since X
stops... I'll try more later (maybe remote debugging and logging).
Comment 1 Bill Nottingham 2003-05-28 23:27:42 EDT
strace would be interesting. But since it's X that's going off into lalaland
with nVidia's driver, the bug is almost certainly in their driver, and there's
really not much of anything we can do to either debug or fix it; sorry. You're
probably best served taking this up with nVidia.

Note You need to log in before you can comment on or make changes to this bug.